WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#40139 closed defect (bug) (invalid)

WP 4.7.3 is misdirecting URLs

Reported by: rmv Owned by:
Milestone: Priority: normal
Severity: critical Version: 4.7.3
Component: Upgrade/Install Keywords:
Focuses: Cc:
PR Number:

Description

Hi,

My name is Rita and I am tasked with maintenance of the web site for The Riverview Public Library, Riverview, Michigan 48193.
I have just installed WordPress 4.7.3 and am running the Education Hub theme.
I have also just updated to Firefox Version 51.0.1 (32-bit).

Since these updates, one of my Menu entries has suddenly become "circular" in that it does not allow me to access the external website for The Library of Michigan Catalog (http://tlnl.ent.sirsi.net/client/en_US/rivw/). Instead of going to that address, it goes to my website = www.riverviewpubliclibrary.com and displays a blank page.

Below, I have pasted the code I am using to access the TLN Catalog resource and for two other TLN resources I am able to access with no problem.

WP Page Name: Catalog
WP Permalink: http://www.stevenhelton.com/riverviewlibrary/Catalog/
WP Page Content Link: <a href="http://tlnl.ent.sirsi.net/client/en_US/rivw/?dt=list"><strong>Catalog</strong></a>
TLN Site Link: http://tlnl.ent.sirsi.net/client/en_US/rivw/?dt=list (Tab Name = Riverview Public Library)
WP Menu Link: <a href="http://tlnl.ent.sirsi.net/client/en_US/rivw/?dt=list"><strong>Catalog</strong></a>

Other attempts to reach the TLN Catalog include:
Attempt 2: <a href="http://tlnl.ent.sirsi.net/client/en_US/rivw/?dt=list/"><strong>Catalog</strong></a>
Attempt 3: <a href="http://tlnl.ent.sirsi.net/client/en_US/rivw/"><strong>Catalog</strong></a>

In every case, the URL I am sent to is http://www.riverviewpubliclibrary.com/ instead of http://tlnl.ent.sirsi.net/client/en_US/rivw/

IMPORTANT NOTE:
If I right click on the Menu Item labeled "Catalog" and request that it open the page in a new Tab or a new Window, the TLN Catalog site opens. However, our library patrons will be extremely reluctant to have to do those extra clicks.

============================================

This TLN link works fine:

WP Page Name: MelCat
WP Permalink: http://www.stevenhelton.com/riverviewlibrary/melcat-2/
WP Page Content Link: <a href="http://elibrary.mel.org/"><strong>MeLCat</strong></a>
TLN Site Link: http://elibrary.mel.org/ (Tab Name = MelCaT, the Michigan eLibrary Catalog and Resource Sharing System)
WP Menu Link: <a href="http://elibrary.mel.org/"><strong>MeLCat</strong></a>

============================================

This TLN link works fine:

WP Page Name: Research
WP Permalink: http://www.stevenhelton.com/riverviewlibrary/Databases/
WP Page Content Link: <a href="http://tln.lib.mi.us/databases/">Online Catalogs &amp; Databases</a>
TLN Site Link: http://tln.lib.mi.us/databases/ (Tab Name = Online Databases)
WP Menu Link: <a href="http://tln.lib.mi.us/databases/"><strong>Research</strong></a>

============================================

I sincerely hope that you can provide me with a solution to this problem. It does appear to be a bug in the new WordPress version or, perhaps, an incompatibility with the new version of Firefox.

Please respond in as timely a way as possible.

Thank you in advance for any help you can give me.

Rita M. Vick

Change History (15)

#1 @rmv
3 years ago

  • Resolution set to invalid
  • Severity changed from normal to critical
  • Status changed from new to closed

#2 follow-up: @rmv
3 years ago

  • Component changed from Menus to Upgrade/Install
  • Resolution invalid deleted
  • Status changed from closed to reopened

Please don't send another message to the effect that my ticket has been deemed "INVALID."

At the very least tell me what is invalid about it.

Know you are busy, but I need to resolve this ASAP.

Sincerely,

Rita M. Vick

#3 @JDTrower
3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Hello @rmv,

While I wasn't the one to mark your ticket as invalid, it's likely it was marked that way because this Trac is used for enhancements and bug reporting for the WordPress core software. I went to your library website and clicking on Catalog in the menu and it takes me to the page http://tlnl.ent.sirsi.net/client/en_US/rivw/ which appears to be what you wanted. This indicated that it is a browser issue and not a bug in WordPress. As a note, in the future, support requests like this should be posted on the support forums to get help with your site. This Trac is not for support issues.

If after getting help from Support, it is determined that there is an actual bug in WordPress core, please feel free to reopen this ticket here and report what the bug is and how to reproduce it.

#4 in reply to: ↑ 2 @SergeyBiryukov
3 years ago

Replying to rmv:

Please don't send another message to the effect that my ticket has been deemed "INVALID."

To clarify, you closed your own ticket in comment:1, not somebody else.

I'm sorry you are experiencing this issue, but as noted above, please try support forums to get help with your site. If it turns out to be a bug in WordPress core, feel free to reopen with steps to reproduce on a clean install.

#5 @netweb
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.