Make WordPress Core

Opened 7 years ago

Closed 6 months ago

Last modified 5 months ago

#40148 closed defect (bug) (duplicate)

wptexturize does not handle mid-word italics properly

Reported by: chriscombsdc's profile chriscombsdc Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Formatting Keywords:
Focuses: Cc:

Description

When referring to the name of a publication, it is necessary to italicize the publication but not the possessive ending.

This leads to wptexturize making the wrong assumption about whether to use a "left" or a "right" quote.

Example post content:

the <em>Daily Mail</em>'s report

Current output:

the Daily Mail‘s report

Desired output:

the Daily Mail’s report

Change History (5)

#1 @lukecavanagh
7 years ago

@chriscombsdc

All <em> should do is just make the text within that italic.

<em>italic text here</em>

So on the left and right quotes do you mean for double quotes?

https://codex.wordpress.org/Fun_Character_Entities
https://codex.wordpress.org/Function_Reference/wptexturize

#2 @chriscombsdc
7 years ago

Hi @lukecavanagh, the mid-word </em> tag is causing the single quote to get the wrong direction when run through wptexturize.

#3 @gitlost
7 years ago

See #18549. As mentioned there, you could try the plugin pap-texturize-1.0.0.zip.

#4 @ellatrix
6 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

I believe this is a duplicate of #18549. Feel free to reopen if I'm mistaken!

#5 @desrosj
5 months ago

  • Milestone Awaiting Review deleted
  • Version changed from 4.7.3 to 3.2.1
Note: See TracTickets for help on using tickets.