WordPress.org

Make WordPress Core

Opened 8 months ago

Last modified 8 months ago

#40160 new defect (bug)

Plugin delete button not working on Chrome browser

Reported by: mp518 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.7.3
Component: Plugins Keywords: reporter-feedback close
Focuses: administration Cc:

Description

wordpress 4.7.3 latest version.

i have updated new version and when i press plugin delete button does not working in chorm browser also this is working fine in mozila firefox.

thank you
mahesh

Attachments (1)

Plugins.png (30.7 KB) - added by mp518 8 months ago.
this button not working

Download all attachments as: .zip

Change History (10)

@mp518
8 months ago

this button not working

#1 @SergeyBiryukov
8 months ago

  • Summary changed from Plugin delete button not working on chorm browser to Plugin delete button not working on Chrome browser

#2 follow-up: @lukecavanagh
8 months ago

@mrkhoros

Which version of Google Chrome and which OS are you using?

#3 in reply to: ↑ 2 @mp518
8 months ago

Replying to lukecavanagh:

@mrkhoros

Which version of Google Chrome and which OS are you using?

Hello @lukecavanagh
I am using Google Chrome Version 57.0.2987.98 (64-bit) and windows 7 professional OS.

#4 follow-up: @subrataemfluence
8 months ago

  • Keywords reporter-feedback added

Could not reproduce the issue on 57.0.2987.98 (64-bit). Plugin just got deleted fine. The only difference is I am on Linux, not on Windows.

Can you please check JS console of your Chrome? It seems to me that there may be some JavaScript errors popping up in your Chrome which is preventing the actual AJAX deletion method to perform correctly. It is more likely your Chrome browser rather than a bug in the Plugin deletion process.

In Firefox the JS error is possibly getting bypassed and taking you to the next page to confirm whether you want to proceed with the deletion process!

In Chrome deletion is done on-page by a JavaScript confirmation alert whereas FireFox redirects us to another page for the same confirmation. The redirection is done from server side hence no JavaScript is required to this point. On that page the deletion is also done using server script.

One more thing. Are you getting any on-screen error message (on Chrome)? If so, please share that as well. It is also worth checking the permission of your actual plugin folder inside wp-content/themes.

#5 in reply to: ↑ 4 @mp518
8 months ago

Hello @subrataemfluence,

There is not show any error on browser console.when I right click to delete button and open new tab there is show "Are you sure you wish to delete these files?" yes and no button for delete file.I have test other popup and its working fine.

#6 follow-up: @lukecavanagh
8 months ago

@mp518

What plugins are active on that site and where is the site hosted?

#7 in reply to: ↑ 6 @mp518
8 months ago

Replying to lukecavanagh:

@mp518

What plugins are active on that site and where is the site hosted?

@lukecavanagh

no active any plugin and site is running on local server.

#8 @mp518
8 months ago

  • Keywords close added

Today i have updated google chrome browser and now working fine with new version.

Thanks

#9 @subrataemfluence
8 months ago

Good to hear that updating Chrome worked for you :)

But I am still on the same version as you were before updating and I have no problem whatsoever. So as I mentioned there was something with your Chrome browser which was preventing the deletion routine to be executed properly.

Note: See TracTickets for help on using tickets.