WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 6 months ago

Last modified 6 months ago

#40207 closed defect (bug) (duplicate)

Select Files button no reaction

Reported by: wpcachepress Owned by:
Milestone: Priority: normal
Severity: major Version: 4.7.3
Component: Media Keywords:
Focuses: Cc:

Description

I’ve done some research:

  1. Windows 10, Chrome 57.0.2987.110 (64-bit);
  2. in my opinion it’s not related to server’s setup: on other browsers – it works;
  1. previous instances of WP 4.7.3 – Select Files works;
  2. new instances of WP 4.7.3 – Select Files no reaction;
  1. it’s partialy Plupload/Moxie issue (http://www.plupload.com/punbb/viewtopic.php?id=14914) – it’s used on that Select Files button by WP core, to generate hidden file input with accept argument which holds accepted mime/file types;
  1. workaround # 1:

6.1. open (using chrome, win10) wp-admin > media > library > click “add new” (while in grid, not list) – “Drop files anywhere to upload” block appears with Select Files button;
6.2. open chrome developer console, find that hidden file input, it’s right before </body> tag, named with eg. id=”html5_1bblpaq4r1ee0e6ich21tge1mus5″ and it has big accept argument with file types;
6.3. copy “accept” attribute big value to your favourite text editor, find “application/zip”, change it to “application/x-zip”, then copy-replace new big list of mimes/file-types to that “accept” attribute (don’t refersh page);
6.4. click on Select Files – it should work;

  1. workaround # 2:

7.1. open chrome settings, show advanced settings at the bottom, under Privacy uncheck “Protect you and your device from dangerous websites”;
7.2. refresh media library page and go to Select Files (like in 6.1. explanation) – the button should work.

  1. I’ve tried application/x-zip-compressed – bug not resolved – button didn’t work.
  2. I think it’s more chrome bug, related to recently strenghtened malware/virus protection.
  3. wp core team should make an exception for this situation to use application/x-zip instead of application/zip with Plupload/Moxie. or just to work with chrome team to sort out this.

Change History (20)

#1 in reply to: ↑ description @wpcachepress
7 months ago

  • Severity changed from normal to major

This ticket was mentioned in Slack in #core by clorith. View the logs.


7 months ago

#3 @wpcachepress
7 months ago

more info on research:

  • bug appears on "non-standard" new WP instances domains, eg. "mydemodomain.press";
  • I've created new WP instance on "standard" domain, "mydemodomain.com" - bug doesn't exist;

it's deeply related to Plupload and/or Chrome's recent security changes

#4 @wpcachepress
7 months ago

also - made tests with https on and off - no difference

#5 follow-up: @swissspidy
7 months ago

Does updating Plupload make any difference? See #40158 for a patch.

#6 in reply to: ↑ 5 @wpcachepress
7 months ago

Yes it works!

Replying to swissspidy:

Does updating Plupload make any difference? See #40158 for a patch.

This ticket was mentioned in Slack in #core by wpcachepress. View the logs.


7 months ago

#8 @SergeyBiryukov
7 months ago

  • Milestone changed from Awaiting Review to 4.7.4

This ticket was mentioned in Slack in #core-media by joemcgill. View the logs.


7 months ago

This ticket was mentioned in Slack in #core by swissspidy. View the logs.


7 months ago

#11 @swissspidy
7 months ago

  • Milestone 4.7.4 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #40158.

@wpcachepress Awesome. Closing this one as a duplicate now because of the working patch on the other ticket.

#12 @techstarter
6 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I have the same issue as described in the ticket that was referred to this one (as a duplicate)

To clarify the exact issue :

  • I have a Wordpress Multisite install recently updated to 4.7.3
  • The base site is a 'world' TLD.
  • I also have domain mapping.
  • Since upgrading to 4.7.3
  • wordpress using the new TLD (xxxx.world/wp-admin) - the 'select files' button does nothing.
  • a 'normal' TLD mapped to the same install (xxxx.com/wp-admin) - the 'select files' button works normally.

I have tried the solution advised from the duplicate ticket :

https://core.trac.wordpress.org/ticket/40158

the DIFF file provided (updating plupload)

It did not resolve... can anyone offer any more insight how i can resolve or troubleshoot?

I am not the only admin, any workarounds that involve editing browser settings are not tenable solutions.

#13 @SergeyBiryukov
6 months ago

  • Milestone set to Awaiting Review

#14 @Kengun
6 months ago

Funny thing is that this problems seems to start with new installations. I have lots of WP sites running without this problem (using Chrome browser on all of them). Today when I installed a fresh new site I got the problem. A Google search got me in here :)

This solution worked for me:

  1. workaround:

7.1. open chrome settings, show advanced settings at the bottom, under Privacy uncheck “Protect you and your device from dangerous websites”;
7.2. refresh media library page and go to Select Files (like in 6.1. explanation) – the button should work.

  • but I dont like turning this setting off. And it's a bit strange that it work on all of my other sites.

#16 @techstarter
6 months ago

okay my apologies -

PLUGIN solution - does work. and is very simple. skip everything else and do this...

  1. DOWNLOAD THE PLUGIN : https://goo.gl/UqVsjU
  1. UPLOAD IT TO YOUR PLUGINS DIRECTORY
  1. ACTIVATE the plugin...
  1. Clear your browser cache / cookies

(chrome > settings > advanced > content settings > all cookies and site data)

  1. Check the 'select files' button ... and the problem should be solved!

Apologies for any confusion caused however this was marked as a duplicate issue for another thread, which proposed a different fix (a patch) which did not work.

#17 @wpcachepress
6 months ago

@techstarter that plugin "uses the same patch" from that other ticket - it just provides original/unmodified version of updated script version. so it's same code, maybe you've done something wrong when applying patch.

#18 @sneader
6 months ago

Just a quick comment that the plupload-fix.zip plugin immediately solved my inability to use "Select Files" in Media. I did not need to clear any cache or cookies. Uploaded, activated and saw immediate relief for this frustrating issue. Looking forward to the permanent fix in 4.7.5.

  • Scott

#19 @Otto42
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #40158.

Seeing as the patch does actually work, both in patch and plugin form, reclosing this as a duplicate of the other ticket.

#20 @SergeyBiryukov
6 months ago

#40641 was marked as a duplicate.

Note: See TracTickets for help on using tickets.