WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 10 months ago

#40210 closed defect (bug) (invalid)

Twenty Seventeen: Content on homepage after installation does not match settings

Reported by: cvorko Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Bundled Theme Keywords:
Focuses: Cc:
PR Number:

Description

After new installation 4.7.3 on the homepage is only a list of latest post (i.e. "Hello Word!") with some widgets. There are no menus.

See example: https://drive.google.com/file/d/0B_zVkWFJBp8bQ2Nub3RIaGRFaEk/view?usp=sharing

When I click on the Customize (and nothing else), I see menu and static page with some sections:

See example: https://drive.google.com/file/d/0B_zVkWFJBp8bRDJHVWFXU2JKYWs/view?usp=sharing

When I click on Save&Publish, the new configuration is saved - although I didn't change any option!

When user clicks on Customize, he should get the same content like it is on the front side - it should be changed only after he changes an option in customizer.

This problem appears only at the beginning, after installation - when I change any option, it is saved, shown on the front side and in the customizer, too. But, the problem in the first step is important for new users.

The similar problem I had in 4.7.2.

Change History (6)

#1 @SergeyBiryukov
3 years ago

  • Component changed from General to Bundled Theme
  • Summary changed from Tweny-seventeen: Content on homepage after installation not is according settings to Tweny Seventeen: Content on homepage after installation does not match settings

#2 @SergeyBiryukov
3 years ago

  • Summary changed from Tweny Seventeen: Content on homepage after installation does not match settings to Twenty Seventeen: Content on homepage after installation does not match settings

#3 follow-up: @alexvorn2
3 years ago

This is because of new theme starter content feature integrated in 4.7,
https://make.wordpress.org/core/2016/11/30/starter-content-for-themes-in-4-7/
and I think it is executed only in Customizer, it should get executed on theme install too (without Live Preview)

#4 @alexvorn2
3 years ago

Related #38624

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

#5 in reply to: ↑ 3 @cvorko
3 years ago

  • Version changed from 4.7.3 to 4.7

Replying to alexvorn2:

This is because of new theme starter content feature integrated in 4.7,
https://make.wordpress.org/core/2016/11/30/starter-content-for-themes-in-4-7/
and I think it is executed only in Customizer, it should get executed on theme install too (without Live Preview)

Thank you, this is the answer :-). And, according to the article, "Starter content is applied and displayed upon entering the customizer".

I agree that it would be less confusing when the starter content would be applied on theme install (when there is no user content) because now we have two predefined "packages":

  • "Hello, world" and some pages on the install
  • starter packet on entering the customizer.

The problem is that users feel confused when the page content changes while entering the customizer (e.g. menu is added). There should be at least a warning, something like "Starter content is applied and it should help you imagine what can stay on the page".

#6 @laurelfulford
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for raising this, @cvorko, and for the explanation, @alexvorn2!

Since this sounds like it's not theme-specific, and is something that should be taken care of in #38624, I'm going to close this specific issue.

If you have any questions about this, just let me know!

Note: See TracTickets for help on using tickets.