WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 22 months ago

#40215 closed defect (bug) (invalid)

's is replaced by 'tain't when 's is followed by a space

Reported by: dezilverhippie Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.3
Component: Formatting Keywords:
Focuses: Cc:

Description

Plural of Dutch words often ends with 's.
If 's is followed by a space: 's becomes automatically 'tain't.
e.g. programma's inclusief becomes programma'tain'tinclusief

Attachments (2)

taint.JPG (10.3 KB) - added by freshmfo 3 years ago.
example of issue
po.JPG (17.6 KB) - added by freshmfo 3 years ago.
my PO file on version 4.9

Download all attachments as: .zip

Change History (12)

#1 @ocean90
4 years ago

  • Keywords reporter-feedback added

Hello @dezilverhippie, welcome to Trac.

Are you using the Dutch language in WordPress or is it still English? I'm asking because this is controlled by two strings, see https://translate.wordpress.org/projects/wp/dev/nl/default?filters%5Bstatus%5D=either&filters%5Boriginal_id%5D=231192&filters%5Btranslation_id%5D=21600838 and https://translate.wordpress.org/projects/wp/dev/nl/default?filters%5Bstatus%5D=either&filters%5Boriginal_id%5D=231191&filters%5Btranslation_id%5D=21600837.

I couldn't reproduce this in a clean install with the current language pack. Are you using a plugin which defines $wp_cockneyreplace (https://core.trac.wordpress.org/browser/tags/4.7.3/src/wp-includes/formatting.php?marks=114-127#L113)?

#2 @dezilverhippie
4 years ago

Hi @ocean90,

I'm using the Dutch language in Wordpress (and it's the nl_BE version I've installed).
The only plugins I've installed are akismet and contact-form-7

#3 @ocean90
4 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This ticket was mentioned in Slack in #polyglots by ocean90. View the logs.


4 years ago

#5 @dezilverhippie
4 years ago

Thanks for your help!

#6 @casiepa
4 years ago

Hi @dezilverhippie,
Thanks for the info, @daveloodts has adapted it so it should solve automatically in the next hours/days.
PS. Feel free to join us on the belgian slack: http://wpmeetup.be/join-slack/

#7 @Presskopp
3 years ago

#42575 was marked as a duplicate.

#8 @freshmfo
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I'm having a similar issue now right now in 4.9

Every 's is suddenly replaced by 'taint.
I'm using the NL_BE dutch version of wordpress.

@freshmfo
3 years ago

example of issue

@freshmfo
3 years ago

my PO file on version 4.9

#9 @davelo
3 years ago

Hi @freshmfo , this should be solved. Still seeing the bug? Latest po-files?

#10 @SergeyBiryukov
22 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.