Make WordPress Core

Opened 9 years ago

Closed 8 years ago

#4022 closed defect (bug) (worksforme)

Possible bug in listing of categories on "Write" > "Post" page

Reported by: elmiller Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1.2
Component: Administration Keywords: Categories
Focuses: Cc:


On the "Write" > "Post" page, I am not seeing all of my categories listed on the right side (only 7 out of 22 of my categories are listed). This makes it impossible for me to put new posts into certain categories. If I try to add a new category on the write post page, it appears momentarily, then disappears. This seems to be a bug in how it lists the categories.

The public view of my page still looks correct and all previous posts are in the correct categories. On the "Manage" > "Categories" page, all of the categories are listed and have the correct number of posts are listed in the "Posts" column.

I have a screen shot and an excerpt from my database showing my categories posted at http://elmiller.wordpress.com/2007/03/23/possible-category-bug/

Change History (10)

#1 @foolswisdom
9 years ago

It sounds like you may still be describing a bug, but the expected (unexpectedly) behavior is you won't see a category that does not have any posts in it.

#2 @foolswisdom
9 years ago

  • Milestone set to 2.3

#3 @Viper007Bond
9 years ago

Unable to reproduce as of the time of this comment. Empty categories get listed for me fine and new ones show up fine as well.

Disable all plugins and try again.

#4 @rob1n
9 years ago

Same here as Viper007Bond.

#5 @elmiller
9 years ago

I have disabled all plugins but am still having the issue. I am not seeing the pattern described above about empty categories. One empty category appears, but other non-empty ones do not.

I also just noticed that my "Manage" > "Categories" page has a miscount. It shows "Uncategorized as having 1 post, but it is actually empty. I wonder if this is related to the other problem, like an error in the wp_posts table or the wp_post2cat table.

I have updated my post at http://elmiller.wordpress.com/2007/03/23/possible-category-bug/ with a couple of new screen shots. Thanks for looking into this.

#6 @elmiller
9 years ago

I've fixed my problem by deleting my categories and recreating them one by one. Through this process, I noticed that the problem has something to do with parent categories. By recreating parent categories, then re-inserting child categories into the parent (but not recreating the children entirely) both parent and child categories now appear on the "Write" > "Posts" page.

I still think a problem exists, but it most likely resulted from the upgrade to 2.1.2 from < 2.1.

#7 @tacker
9 years ago

I ghave a similar problem. In "Manage > Categories" only the level 0 categories are listed although I have many sub categories under them which are correctly listed in the "Manage > Posts: Browse Category…" dropdown.

wp_list_categories also list only the categories visible in "Manage > Categories".

Any Idea how to fix this without recreating them?

My blog is on trunk.

#8 @tacker
9 years ago

  • Cc tacker added

#9 @tacker
9 years ago

worksforme in r5301

#10 @markjaquith
8 years ago

  • Milestone 2.3 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Old, with a bunch of "works for me's"

Note: See TracTickets for help on using tickets.