WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#40222 closed enhancement (duplicate)

Search is not consistent in Dashboard

Reported by: Travel_girl Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: ui, accessibility Cc:

Description

In the WordPress-Backend are multiple Search-fields and those are all different.

For a better User Experience it would be better, if their would look and work the same way.

Search for

  • Posts
  • Pages
  • Media
  • Plugins
  • Themes

I suggest to have the search field in the upper right corner with an button "Search xy" like in the Post version. In this way it would be easier to navigate.

Also when you want to install new plugins or themes, while you are typing the keywords, the search starts automatically and have wrong results sometimes.

Attachments (7)

search posts.png (326.9 KB) - added by Travel_girl 14 months ago.
Search Posts
search page.png (308.7 KB) - added by Travel_girl 14 months ago.
Search Pages
search media.png (352.4 KB) - added by Travel_girl 14 months ago.
Search Media
plugin search.png (547.5 KB) - added by Travel_girl 14 months ago.
plugin search
plugin-install.png (617.8 KB) - added by Travel_girl 14 months ago.
Plugin search for install
theme-search.png (1.9 MB) - added by Travel_girl 14 months ago.
theme search
themes-install.png (1.3 MB) - added by Travel_girl 14 months ago.
Theme search for install

Change History (14)

@Travel_girl
14 months ago

Search Posts

@Travel_girl
14 months ago

Search Pages

@Travel_girl
14 months ago

Search Media

@Travel_girl
14 months ago

plugin search

@Travel_girl
14 months ago

Plugin search for install

@Travel_girl
14 months ago

theme search

@Travel_girl
14 months ago

Theme search for install

#1 @ocean90
14 months ago

  • Keywords close added

Hi @Travel_girl, thanks for the ticket and the screenshots. There are already a few tickets about this, main ticket seems to be #31818.

#25103
Submit buttons on form fields in the Add Media panel
#31818
Uniform Search Form Display/Experience
#34881
Invalid HTML around the input field for searching themes
#37353
Unify look and feel of search forms and results across the admin
#38211
Interference of AJAX search with input field auto-complete

This ticket was mentioned in Slack in #design by travelgirl. View the logs.


14 months ago

#3 follow-up: @Travel_girl
14 months ago

@ocean90 okay, thanks and sorry for the douple tickets. How do you find the other tickets? I was searching a bit and could not find them.

#4 in reply to: ↑ 3 @ocean90
14 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #31818.

Replying to Travel_girl:

How do you find the other tickets?

I remembered that @afercia added a keyword to those tickets. 😉

#5 @afercia
14 months ago

@Travel_girl you're welcome to join the discussion on #31818, to be honest there's no progress on that ticket since a while but it's definitely on the accessibility team radar. Also, a11y meetings happen on Mondays at 18 UTC if you're interested :) I'd say the best way to search previous tickets on Trac is using Google, prepending the search with site:core.trac.wordpress.org as the Trac search results are often not so ideal.

#6 @Travel_girl
14 months ago

@afercia thank you for your answers - will see you in #31818 :-)

This ticket was mentioned in Slack in #accessibility by rianrietveld. View the logs.


14 months ago

Note: See TracTickets for help on using tickets.