WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 14 months ago

Last modified 13 months ago

#40305 closed defect (bug) (fixed)

Image popup toolbar does not support Chrome Beta

Reported by: programmin Owned by: azaozz
Milestone: 4.7.4 Priority: high
Severity: normal Version:
Component: TinyMCE Keywords: fixed-major
Focuses: ui, javascript Cc:

Description

This is probably a Chrome bug deep down, but if you click an image in the wp editor, it doesn't show the image popup toolbar as in previous versions of Chrome.

Tested in Version 58.0.3029.33 beta (64-bit)

Change History (19)

#2 @programmin
14 months ago

The Chrome developers pointed out this recent change in Chrome, that an invalid argument to a function is being called: https://www.chromestatus.com/feature/5696359768260608

I do hope this is fixed in Wordpress' MCE before the Chrome 58 goes from beta to stable, later this month.

#3 @azaozz
14 months ago

  • Milestone changed from Awaiting Review to 4.7.4
  • Priority changed from normal to high
  • Version 4.7.3 deleted

@programmin thanks for following up. Yes, we have to update TinyMCE asap, this should be fixed in the latest version.

#4 @azaozz
14 months ago

#40360 was marked as a duplicate.

This ticket was mentioned in Slack in #core-editor by azaozz. View the logs.


14 months ago

#6 @swissspidy
14 months ago

I can confirm this issue.

The image toolbar isn't shown when clicking on an image, but it is when making a text selection either via mouse or keyboard.

#7 @azaozz
14 months ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 40398:

Update TinyMCE to 4.5.6. Has many improvements and bug fixes. Changelog: https://github.com/tinymce/tinymce/blob/4.5.x/changelog.txt.

Fixes #40305 for trunk.

#8 @azaozz
14 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopen for 4.7.4.

#9 @azaozz
14 months ago

In 40399:

TinyMCE: update the tests for version 4.5.6. Remove default plugins tests, it is quite pointless to keep repeating them at this point.

See #40305.

#10 @swissspidy
14 months ago

  • Keywords fixed-major added

#11 follow-up: @programmin
14 months ago

That's odd, my wp test install I updated to nightly build https://wordpress.org/nightly-builds/wordpress-4.7-latest.zip and it still gives exception:

Uncaught DOMException: Failed to execute 'setBaseAndExtent' on 'Selection': There is no child at offset 1.

#12 @swissspidy
14 months ago

@programmin Well, that sounds like it's the nightly build for the 4.7 branch. [40398] is only in trunk so far, so you need https://wordpress.org/nightly-builds/wordpress-latest.zip instead.

#13 @swissspidy
14 months ago

FWIW, [40398] fixed the issue for me.

#14 in reply to: ↑ 11 @azaozz
14 months ago

Replying to programmin:

Works properly here too. Refreshed the nightly (wordpress-latest.zip) and confirmed it contains the new TinyMCE. Can you test again please.

#15 @programmin
14 months ago

Looks like that works! So Chrome users would need to wait for WP 4.8 for that to work again?

#16 @swissspidy
14 months ago

@programmin The fix is in the 4.7.4 milestone, which means users would have to wait for WordPress 4.7.4.

This ticket was mentioned in Slack in #core by swissspidy. View the logs.


14 months ago

#18 @azaozz
14 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 40419:

Update TinyMCE to 4.5.6. Has many improvements and bug fixes. Changelog: https://github.com/tinymce/tinymce/blob/4.5.x/changelog.txt.

Merges [40398] to the 4.7 branch.

Props programmin, eclev91 and boldwater for finding and reporting this.
Fixes #40305.

#19 @ocean90
13 months ago

#40498 was marked as a duplicate.

Note: See TracTickets for help on using tickets.