WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 7 weeks ago

#40358 closed defect (bug) (worksforme)

Twenty seventeen header media on homepage not responsive

Reported by: queensyd Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.3
Component: Bundled Theme Keywords:
Focuses: Cc:
PR Number:

Description

Hi,

I have made a site with the Twenty-seventeen theme and it looks good on the pc, but not on my smartphone, a Samsung Galaxy A3-2016. What happens is that the homepage header photo is scaled in width, while maintaining the same height, and this looks ridiculous. Can you look into it and make sure the aspect ratio of the home page header photo remains constant?

Thanks and regards, Ronald
queensyachtdesign.nl

Attachments (1)

Screen Shot 2019-10-24 at 3.45.34 PM.png (729.8 KB) - added by desrosj 7 weeks ago.

Download all attachments as: .zip

Change History (3)

#1 @garrett-eclipse
5 months ago

  • Component changed from General to Bundled Theme
  • Keywords close 2nd-opinion added

Hi @queensyd

Reviewing the TwentySeventeen theme the header image is setup as a background cover and meant to keep it's height. To keep it's aspect ratio it would need to be an inline image.

This appears to be a design decision for the bundled theme so am marking for closure and moving to the Bundled Theme component for a 2nd-opinion.

If you would like assistance in customizing the theme to your needs please reach out via the support forums - https://wordpress.org/support/

#2 @desrosj
7 weeks ago

  • Keywords close 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I did some testing here to try and recreate an issue similar to what you described. In my testing, though, I couldn't get the header to do anything except the correct intended behavior.

I looked up the A3-2016, and the screen dimensions are 720 x 1280(~312 ppi pixel density). The attached screenshot is what I see with those screen properties.

If someone with this device is still experiencing this issue, please reopen and provide more steps to reproduce. Screenshots would also be very helpful.

Note: See TracTickets for help on using tickets.