WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#40466 closed defect (bug) (duplicate)

Multisite fails to rewrite upload path on main site

Reported by: daniel berhane Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.3
Component: Networks and Sites Keywords:
Focuses: multisite Cc:

Description

This is a follow-up to #12002.

After removing the /blog/ slug On options-permalink.php, the media files display the wordpress subdirectory on the urls.

Steps:

Install wordpress in its own directory
Activate multisite with subsites
Switch one of the subsite into becoming main site
Everything works smoothly including images

However, image urls contain wordpress directory.

The urls are like this:

Domain.com/wordpress/wp-content/uploads/image-title.jpg

Instead of

Domain.com/wp-content/uploads/image-title.jpg

Is this the way it is designed to work? Or a bug?
Thanks.

Change History (1)

#1 @swissspidy
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #40465.

Note: See TracTickets for help on using tickets.