WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#40498 closed defect (bug) (duplicate)

TinyMCE Bug on media modification modal

Reported by: casshern83fr Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.3
Component: TinyMCE Keywords:
Focuses: Cc:

Description (last modified by ocean90)

The function use setBaseAndExtent, make crash with version chrome 58, https://www.chromestatus.com/feature/5632500684554240

From dev version
tinymce\classes\dom\Selection.js

Line 644: 				// WebKit egde case selecting images works better using setBaseAndExtent when the image is floated
Line 645: 				if (!rng.collapsed && rng.startContainer == rng.endContainer && sel.setBaseAndExtent && !Env.ie) {
Line 650: 								sel.setBaseAndExtent(
Line 657: 								// Since the setBaseAndExtent is fixed in more recent Blink versions we
Line 662: 									sel.setBaseAndExtent(node, 0, node, 1);

tinymce\js\tinymce\tinymce.js (5 hits)

// WebKit egde case selecting images works better using setBaseAndExtent when the image is floated
Line 18266: 				if (!rng.collapsed && rng.startContainer == rng.endContainer && sel.setBaseAndExtent && !Env.ie) {
Line 18271: 								sel.setBaseAndExtent(
Line 18278: 								// Since the setBaseAndExtent is fixed in more recent Blink versions we
Line 18283: 									sel.setBaseAndExtent(node, 0, node, 1);
// WebKit egde case selecting images works better using setBaseAndExtent when the image is floated
Line 18266: 				if (!rng.collapsed && rng.startContainer == rng.endContainer && sel.setBaseAndExtent && !Env.ie) {
Line 18271: 								sel.setBaseAndExtent(
Line 18278: 								// Since the setBaseAndExtent is fixed in more recent Blink versions we
Line 18283: 									sel.setBaseAndExtent(node, 0, node, 1);

Change History (1)

#1 @ocean90
2 years ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #40305.

Hello @casshern83fr, welcome to WordPress Trac!

Thanks for your report. This issue will be fixed in WordPress 4.7.4, which release is planned for today.

Note: See TracTickets for help on using tickets.