WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#40514 closed defect (bug) (invalid)

Cannot pull favorites from Wordpress.org when adding plugin(s) to WP installs

Reported by: Vision Hive Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.4
Component: Plugins Keywords:
Focuses: administration Cc:

Description

My user name is "Vision Hive". My 15 years of php programming experience suspect that the space in the user name is what is not being handled correctly in the api/call to wordpress.org. However, this feature used to work just fine and my user name has not changed so it could be something else.

Steps to reproduce: Sign up for an account on wordpress.org and choose a username with a space (or maybe other non-alpha characters). Go to any wordpress installation and open the plugin -> add and then select "favorites" and enter your username (or mine). Sit back and witness failure.

Personal notes: please don't be lazy and suggest changing my user name to not have a space as a fix. That would be a sloppy workaround, not a fix. It would not solve the problem for any number of *other* users that have the space in their usernames, and it does not address the core issue which could affect any number of special characters that are perfectly normal/legal in a username. It would be like asking someone to change their name because it has a dash in it, or something else equally inconsiderate/insensitive.

Attachments (3)

wp-org.jpg (190.5 KB) - added by Vision Hive 14 months ago.
my favorites on wordpress.org
wp-admin.jpg (123.7 KB) - added by Vision Hive 14 months ago.
failure
Screenshot 2017-04-25 12.50.37.png (251.8 KB) - added by bradparbs 14 months ago.
correct-results

Download all attachments as: .zip

Change History (6)

@Vision Hive
14 months ago

my favorites on wordpress.org

@Vision Hive
14 months ago

failure

#1 @bradparbs
14 months ago

  • Resolution set to invalid
  • Status changed from new to closed

You WordPress.org user name is vision-hive, not vision hive.

Using that in the favorites input returns expected results for me.

@bradparbs
14 months ago

correct-results

#2 @johnbillion
14 months ago

  • Milestone Awaiting Review deleted

#3 @dd32
14 months ago

FWIW this wasn't invalid, Vision Hive is indeed their username, the new plugin directory API only queries by user_slug (which usually matches the username on w.org, except where spaces are involved).

If anyone feels like fixing it, create a ticket on meta.trac.wordpress.org and attach a patch touching the following code: https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/plugins/plugin-directory/class-plugin-directory.php?marks=678-680&rev=5461#L670

Note: See TracTickets for help on using tickets.