WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#40543 closed defect (bug) (wontfix)

Wordpress editor breaks Bootstrap html popups

Reported by: Tina Hammar Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

Wordpress editor converts a double straight " to a right double ” on Bootstrap popups with data-html="true" attribute.
It converts the ending double straight of the data-content attribute if it contains html.

Screencast:
https://www.screencast.com/t/WX0HayZTOqd

This works

<a tabindex="0" role="button" data-toggle="popover" data-trigger="focus" data-html="true" data-container="body" data-placement="top auto" title="Plats" data-content="hello"></a>

With this, the ending " (double straight) in data-content is converted to a ” (right double) which destroys the page html.

<a tabindex="0" class="space-pos-span" role="button" data-toggle="popover" data-trigger="focus" data-html="true" data-container="body" data-placement="top auto" title="Plats" data-content="<p>hello</p>"></a>

Detailed report with link to test installation:
https://wp-types.com/forums/topic/layouts-visual-editor-cell-destroys-html-bootstrap-popover-content/#post-516221

Change History (2)

#1 @bedas
2 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

It's not a BUG.
Solution here: http://jsfiddle.net/J7nDz/5/

Depends on how you initialise the PopUp

Thanks to HudsonValleyWebDesign

#2 @ocean90
2 years ago

  • Milestone Awaiting Review deleted
  • Version 4.7.4 deleted
Note: See TracTickets for help on using tickets.