WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#40563 closed defect (bug) (duplicate)

Timeout error caused by flock() function on NFS mounts

Reported by: mattj1s Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.4
Component: Rewrite Rules Keywords:
Focuses: Cc:
PR Number:

Description

The flock() function in insert_with_markers() in the wp-admin/includes/misc.php file doesn't work on NFS mounts. The issue is documented here: http://php.net/manual/en/function.flock.php#82521 also here: http://php.net/manual/en/function.flock.php#68875

To reproduce the error, access the Settings > Permalinks page in WordPress 4.7.4 on an NFS mount. It results in a timeout error.

Change History (1)

#1 @dd32
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @mattj1s and welcome to WordPress Trac.

We're tracking this issue over in #38595 - it was originally introduced in #31767

Note: See TracTickets for help on using tickets.