WordPress.org

Make WordPress Core

Opened 14 months ago

Last modified 14 months ago

#40585 reopened defect (bug)

'Update' vs 'Schedule'

Reported by: micheleconversano Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords: has-patch needs-testing
Focuses: Cc:

Description

Hi, today i work with WordPress and i noticed a problem. My timeline event is: 1) I have an article "X" published of the 26 april at 20.00. 2) Today, 27 april at 18.02 i start the edit the article 3) At 18.15 finish edit article and modified date of article in pubblication in 27 april at 18.15 4) Now i don't look button "Update" but i look button "Planning".

I have feeling that WordPress don't check date in this moment (18.15) but check date open edit article (18.02).

The article is pubblished in all cases but theoretically the article is deleter on the google serp for some minutes.

Sorry for my english :)

Attachments (1)

40585.diff (829 bytes) - added by swissspidy 14 months ago.

Download all attachments as: .zip

Change History (8)

#1 @Ipstenu
14 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I'm sorry but this is not a bug report for issues with WordPress core

You can post asking for help debugging the situation in https://wordpress.org/support/

If you don't change the time/date stamp for WordPress, then when you publish a post it will be 'now' even if you save it as pending.

If you DO edit the time or day, WordPress keeps that no matter what future changes you make.

#2 @swissspidy
14 months ago

  • Milestone Awaiting Review deleted

#3 @SergeyBiryukov
14 months ago

  • Component changed from General to Posts, Post Types

#4 @SergeyBiryukov
14 months ago

  • Summary changed from update vs planning to 'Update' vs 'Schedule'

@swissspidy
14 months ago

#5 @swissspidy
14 months ago

#40693 was marked as a duplicate.

#6 @swissspidy
14 months ago

  • Keywords has-patch added
  • Milestone set to Awaiting Review
  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopening as per #40693.

#7 @swissspidy
14 months ago

  • Keywords needs-testing added

The patch is by micheleconversano, just so we don't forget to give props if legit.

Note: See TracTickets for help on using tickets.