WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#40620 closed task (blessed) (fixed)

Pin the WordPress Importer version when testing on Travis

Reported by: johnbillion Owned by: johnbillion
Milestone: 4.8 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Focuses: Cc:
PR Number:

Description

Dependencies which aren't pinned to some sort of version constraint often end up breaking things at some point in time, as we've seen with PHPUnit 6 (#40100).

The WordPress Importer plugin that's checked out during the Travis tests should be pinned to a version (0.6.3) instead of trunk.

Change History (2)

#1 @johnbillion
2 years ago

  • Owner set to johnbillion
  • Resolution set to fixed
  • Status changed from new to closed

In 40562:

Build/Test Tools: Pin the WordPress Importer plugin to version 0.6.3 when testing on Travis.

Fixes #40620

#2 @netweb
2 years ago

Just as a heads up, looping in @boonebgorges @danielbachhuber

  • Daniel maintains and uses WordPress Importer (possibly /trunk) in wp-cli
Note: See TracTickets for help on using tickets.