WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 3 months ago

#40627 closed task (blessed) (duplicate)

Remove SWFUpload

Reported by: azaozz Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upload Keywords:
Focuses: Cc:

Description

Development of SWFUpload stopped in 2010. It has been deprecated in core since 2011 when we switched to using Plupload in WordPress 3.3. Most of its functionality is now native in all browsers.

We've been maintaining it for over five years, but in the spirit of https://make.wordpress.org/core/2017/04/23/target-browser-coverage/ it's time to say "Goodbye!".

Change History (2)

#1 @azaozz
7 months ago

There are probably old plugins that still use SWFUpload. Will need to make a fallback so they don't completely fail. Thinking that a simple <input type="file" multiple ...> and a JS noop will be sufficient.

Last edited 7 months ago by azaozz (previous) (diff)

#2 @azaozz
3 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #41752.

Ugh, my mistake. Closing this in favor of 41752.

Note: See TracTickets for help on using tickets.