WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#40652 closed defect (bug) (invalid)

Plugin readme.txt can't handle multiple == Upgrade Notice ==

Reported by: stiofansisland Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.4
Component: Upgrade/Install Keywords:
Focuses: docs Cc:
PR Number:

Description

Recently we tried to add a second == Upgrade Notice == to our readme.txt
When we added it like:

== Upgrade Notice ==

= 1.6.19 =
SECURITY: WP Session class lib can expose the Session ID publicly - Please Update to 1.6.19 or greater to fix.

= 1.6.11 =
Google Analytics BREAKING CHANGE, you must update settings at GD>General>Google Analytics: once you have updated.

It showed both messages on the pluign screen instead of 1.

When we added it like this:

== Upgrade Notice ==

= 1.6.19 =
SECURITY: WP Session class lib can expose the Session ID publicly - Please Update to 1.6.19 or greater to fix.

= 1.6.11 =
Google Analytics BREAKING CHANGE, you must update settings at GD>General>Google Analytics: once you have updated.

It did not show at all.

So it looks like the == Upgrade Notice == can't handle multiple versions?

Change History (1)

#1 @dd32
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

The WordPress.org plugin repo does support multiple versions listed in the Upgrade Notice section, however it's only used when it matches the latest version specifically.

Check out the format specified by the readme standard on https://wordpress.org/plugins/developers/#readme

Sidenote: This trac instance is for WordPress the software, for bugs related to the plugin directory, you should use the Meta Trac instance instead.

Note: See TracTickets for help on using tickets.