WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#40684 closed defect (bug) (duplicate)

Notices in edit-comments.php page

Reported by: sebastian.pisula Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords: has-patch
Focuses: Cc:

Description

Scenario:

  1. Activate WooCoommerce plugin,
  2. Add product,
  3. Add review to products,
  4. Deactive WooCommerce plugin,
  5. Go to wp-admin/edit-comments.php page.

Trying to get property of non-object

wp-admin/includes/class-wp-comments-list-table.php:770

Call Stack:

WP_Comments_List_Table->column_response()
wp-admin/includes/class-wp-list-table.php:1300
WP_List_Table->single_row_columns()
wp-admin/includes/class-wp-comments-list-table.php:498
WP_Comments_List_Table->single_row()
wp-admin/includes/class-wp-list-table.php:1229
WP_List_Table->display_rows()
wp-admin/includes/class-wp-list-table.php:1213
WP_List_Table->display_rows_or_placeholder()
wp-admin/includes/class-wp-comments-list-table.php:453
WP_Comments_List_Table->display()
wp-admin/edit-comments.php:325

Attachments (1)

40684.patch (1.1 KB) - added by sebastian.pisula 4 years ago.

Download all attachments as: .zip

Change History (3)

#1 @sebastian.pisula
4 years ago

  • Keywords has-patch added

#2 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #36058.

Note: See TracTickets for help on using tickets.