WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 22 months ago

#40690 closed defect (bug) (fixed)

Update TinyMCE to 4.6.0

Reported by: azaozz Owned by: azaozz
Milestone: 4.8 Priority: normal
Severity: normal Version: 4.8
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Has a lot of new features and tons of bug fixes, among them -- the link boundaries enhancement!
Changelog: https://www.tinymce.com/docs/changelog/#version460-may42017.

Attachments (1)

40690.patch (2.1 KB) - added by iseuldebot 2 years ago.

Download all attachments as: .zip

Change History (11)

#1 follow-up: @azaozz
2 years ago

Note: from this version TinyMCE doesn't support IE < 11.

#2 @azaozz
2 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 40583:

TinyMCE: update to 4.6.0. Has many new features and bug fixes, changelog: https://www.tinymce.com/docs/changelog/#version460-may42017.

Fixes #40690.

#3 @azaozz
2 years ago

In 40584:

TinyMCE: remove the pre-4.6.0 tests. Move regression testing for obsolete tags and attributes to the default QUnit tests.

See #40690.

#4 @azaozz
2 years ago

In 40585:

Fix linting errors in tinymce-obsolete.js.

See #40690.

#5 in reply to: ↑ 1 @Presskopp
2 years ago

Replying to azaozz:

Note: from this version TinyMCE doesn't support IE < 11.

Another note:
That's fine, following
https://make.wordpress.org/core/2017/04/23/target-browser-coverage/

@iseuldebot
2 years ago

#6 follow-up: @iseulde
2 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Going to reopen because I think there's a better way to add custom UI to the MCE Factory. See patch above.

#7 in reply to: ↑ 6 @azaozz
2 years ago

Replying to iseulde:

Yeah, this looks good. I'm a bit concerned about plugins that may have copied the "old way" of extending this, but they can copy the fix too :)

#8 @azaozz
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 40587:

TinyMCE: improve adding of custom UI to the MCE Factory.

Props iseulde.
Fixes #40690.

#9 @swissspidy
2 years ago

#38978 was marked as a duplicate.

#10 @westonruter
22 months ago

In 42041:

Tests: Remove references to deleted JS files in QUnit tests.

Amends [41570], [40584].
See #41755, #40690.

Note: See TracTickets for help on using tickets.