WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#40712 closed task (blessed) (fixed)

Change Travis integration to post to Slack from the WordPress/wordpress-develop repo

Reported by: pento Owned by: pento
Milestone: 4.8 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: fixed-major
Focuses: Cc:

Description

The secure key in .travis.yml needs to be updated for the new repo and integration.

Change History (15)

#1 @pento
2 years ago

  • Owner set to pento
  • Status changed from new to assigned

#2 @pento
2 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 40604:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

Props jorbin for getting the ball rolling so long ago, unprops jorbin because his Travis build can finally be retired.

Fixes #40712.

#3 @pento
2 years ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for backporting the new key to branches.

I'll leave backporting until we can confirm that messages are being delivered.

#4 @pento
2 years ago

In 40613:

Build/Test: Add an intentionally failing test.

To ensure that Travis is sending messages to Slack, a test needs to fail, so here's a failing test.

This failing test (and no other failing tests) will be reverted once Travis confirms that it isn't failing to message Slack about failing tests.

See #40712.

#5 @pento
2 years ago

In 40614:

Build/Test: Revert that failing test.

Now that Travis has confirmed that it is sending messages to Slack when a test fails, we no longer need a failing test.

The failing test added in [40613] is reverted, as Travis has failed to fail at notifying us about failing tests.

See #40712.

#6 @jorbin
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 40616:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Backports [40604] to 4.7

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

Props jorbin for getting the ball rolling so long ago, unprops jorbin because his Travis build can finally be retired. Props Pento.

Fixes #40712.

#7 @jorbin
2 years ago

In 40617:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Backports [40604] to 4.6

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

Props jorbin for getting the ball rolling so long ago, unprops jorbin because his Travis build can finally be retired. Props Pento.

See #40712.

#8 @jorbin
2 years ago

In 40618:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Backports [40604] to 4.6

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

Props jorbin for getting the ball rolling so long ago, unprops jorbin because his Travis build can finally be retired. Props Pento.

See #40712.

#9 @jorbin
2 years ago

In 40619:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Backports [40604] to 4.4

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

Props jorbin for getting the ball rolling so long ago, unprops jorbin because his Travis build can finally be retired. Props Pento.

See #40712.

#10 @jorbin
2 years ago

In 40620:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Backports [40604] to 4.3

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

Props jorbin for getting the ball rolling so long ago, unprops jorbin because his Travis build can finally be retired. Props Pento.

See #40712.

#11 @jorbin
2 years ago

In 40621:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Backports [40604] to 4.2

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

Props jorbin for getting the ball rolling so long ago, unprops jorbin because his Travis build can finally be retired. Props Pento.

See #40712.

#12 @jorbin
2 years ago

In 40622:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Backports [40604] to 4.1

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

Props jorbin for getting the ball rolling so long ago, unprops jorbin because his Travis build can finally be retired. Props Pento.

See #40712.

#13 @jorbin
2 years ago

In 40623:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Backports [40604] to 4.0

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

Props jorbin for getting the ball rolling so long ago, unprops jorbin because his Travis build can finally be retired. Props Pento.

See #40712.

#14 @jorbin
2 years ago

In 40624:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Backports [40604] to 3.9

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

3.9 never had slack notifications....until now!

Props jorbin for getting the ball rolling so long ago, unprops jorbin because his Travis build can finally be retired. Props Pento.

See #40712.

#15 @jorbin
2 years ago

In 40625:

Build/Test: Post Travis results to Slack from WordPress/wordpress-develop

Backports [40604] to 3.8

Now that the WordPress/wordpress-develop GitHub repo is syncing correctly, we can use it for Travis integration.

A long long time
I Can Still remember how
That Testing used to make me smile
And I knew if I had my chance
That Travis could make the tests dance
And Maybe they'd pass for a while

But personal accounts made me shiver
with ever slack notification delivered
Red Frogs on the doorstep
I couldn't take one more step

I can't remember if I cried
When dd32 setup wordpress/wordpress-develop
Something touched nacin deep inside
The day my mirror died
So

Bye Bye Jorbin's Travis
Drove Pento to the Levee but the levee was dry
And netweb was drinking whisky and rye
Singin' this'll be the day that my mirror die
This'll be the day my mirror die

See #40712.

Note: See TracTickets for help on using tickets.