Make WordPress Core

Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#4072 closed defect (bug) (wontfix)

is_tag and get_tag_link clash with similarly named bbPress functions

Reported by: filosofo Owned by:
Milestone: Priority: high
Severity: major Version:
Component: Administration Keywords: has-patch is_tag get_tag_link bbpress
Focuses: Cc:

Description

[5149] introduced functions is_tag and get_tag_link, which are also bbPress functions, messing up any WP-bbPress integrations.

My patch changes is_tag to is_wp_tag and get_tag_link to get_wp_tag_link.

Attachments (1)

tag.patch (3.6 KB) - added by filosofo 15 years ago.

Download all attachments as: .zip

Change History (8)

@filosofo
15 years ago

#1 follow-up: @matt
15 years ago

Generally WP takes precedence in things like this, since bbPress' userbase is so much smaller. get_link isn't bad but is_wp_tag is ugly.

#2 in reply to: ↑ 1 @filosofo
15 years ago

Replying to matt:

Generally WP takes precedence in things like this, since bbPress' userbase is so much smaller. get_link isn't bad but is_wp_tag is ugly.

Okay, my suggested names are ugly. But if we keep the WP names as is, then down the road someone's going to have to think of alternate non-ugly names for the bbPress functions.

I'm just suggesting that we expend the creative re-naming effort now, before these functions have officially been released in WP, and before bbPress users lose their existing template functions and wonder what happened.

#3 @rob1n
15 years ago

  • Priority changed from normal to high

#4 @spencerp
15 years ago

Yes, I agree with filosofo. (No offense of course!) This was just one of the issues folks including me were having when running UTW and bbPress together before sigh.

Reference links about it:
http://www.neato.co.nz/archives/2007/02/04/ultimate-tag-warrior-314159265/
"The thing where bbPress and UTW wouldn’t play nice because UTW had a is_tag function, and bbPress had one too. [If UTW sees that the is_tag function already exists, it isn’t declared; and there’s a is_utwtag function that bbPress users can use instead. Yeah.]"

I posted this comment on her blog previous to that UTW version even:
"spencerp January 22nd, 2007

Hi Christine,

Would it be possible to fix the compatibility issue between bbPress and UTW? Here’s a link to the thread at the bbPress support forums.

Quoted traveljunky’s post:
“this bug is caused by the function is_tag(), which both utw and bbpress use, so what i just did right now was search through the utw-plugin-folder with dreamweaver for that tag, found it three times and changed it to is_utwtag(). no idea if i can just do that without problems appearing later but for now it seems to work.”

Through the file(s) changing this: is_tag() to: is_utwtag() seems to help those running bbPress and WordPress running the UTW plugin. I was just was wondering.. ;):)
"

Here's the bbPress post about it as well:
http://bbpress.org/forums/topic/78?replies=5#post-2374

#5 @rob1n
15 years ago

  • Milestone changed from 2.2 to 2.3

Tags are in 2.3 now.

#6 @ryan
14 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

bbPress will be doing some changes to accommodate.

#7 @Nazgul
14 years ago

  • Milestone 2.3 deleted
Note: See TracTickets for help on using tickets.