WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#4075 closed defect (bug) (duplicate)

page slug gets changed on comment

Reported by: Denis-de-Bernardy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

reproduce:

http://localhost/index.php/page-1/

change name to page 1 test, url remains:

http://localhost/index.php/page-1/

add a comment. slug changes:

http://localhost/index.php/page-1-test/

Change History (3)

comment:1 follow-up: Denis-de-Bernardy7 years ago

  • Severity changed from major to normal

update:

it turns out it only occurs when the singular plugin is active. This strikes me as odd though, because this plugin filters two hooks:

add_action('publish_post', 'singular_post', 8);
add_action('edit_post', 'singular_post', 8);

And I cannot picture any reason for a new comment to trigger the edit_post hook.

comment:2 in reply to: ↑ 1 Nazgul7 years ago

Replying to Denis-de-Bernardy:

And I cannot picture any reason for a new comment to trigger the edit_post hook.

See #3908

comment:3 rob1n7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Same as #3908, pretty much.

Note: See TracTickets for help on using tickets.