WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#40770 closed defect (bug) (worksforme)

Probable bug: Wordpress and its plugins will not update under FCGI

Reported by: itmonitor Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: Cc:
PR Number:

Description

Hi!

Issue: I moved my Wordpress website into another hosting company and did some tweaks in the VPS OpenVZ server (Apache 2.4 - CENTOS 6.9 x86_64 - PHP5.6+7.0). I disabled SuPHP and enabled the FCGI handler on PHP, as the FCGI has a better performance. Days later when I tried to update Wordpress into v. 4.7, it will not update and request me the FTP credentials. Also the plugin update requested the FTP credentials.

Solution: my hosting provider and after a lot (really many) tries, managed to solve the Wordpress file permission issue. Only chmod did not resolve. They found out that inorder to Wordpress+plugins to update the PHP handler must be SuPHP. FCGI was blocking the updates, or so it seems.

Not sure this could be a bug, but I report it here so you can check.

Hope to have helped.

rgs

IM

Change History (2)

#1 @Ipstenu
2 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Anecdotal but a lot of people, myself included, use fcgi php without issues. Most likely this is a user permission error caused by the swap from suphp. I had to reset my file permissions to get php to run properly.

Make sure the updates folder has the right permissions and that your apache user can write files.

#2 @ocean90
2 years ago

  • Milestone Awaiting Review deleted
  • Version 4.7.4 deleted
Note: See TracTickets for help on using tickets.