WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#40824 closed enhancement (duplicate)

provide UX hints when 'DISALLOW_FILE_MODS' is TRUE

Reported by: ixmati Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.5
Component: Administration Keywords:
Focuses: ui, administration Cc:
PR Number:

Description

With this config:

define( 'DISALLOW_FILE_MODS', true );

the updates page (wp-admin/update-core.php) in the admin UX just disappears for users with the administrator role (and maybe other UX also), which is disconcerting and unexpected.

It would be better to continue to deliver all the same admin navigation with this config, but include messages that explain that file modifications are turned off.

I spent quite a while trying to figure out why admin navigation was missing until I figured this reason out.

Change History (1)

#1 @johnbillion
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #25219.

Note: See TracTickets for help on using tickets.