Make WordPress Core

Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#40830 closed enhancement (maybelater)

Widgets: add a warning that changes are published instantly on the admin screen

Reported by: celloexpressions's profile celloexpressions Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Widgets Keywords: has-patch has-screenshots
Focuses: ui Cc:

Description

Every change made on the widgets admin screen is published instantly, making it live on the user's site. This includes adding a widget without configuring any settings and other things that probably shouldn't go live before they're ready. For this reason, we added a "manage with live preview" link to this screen previously.

To further emphasize the usability problems with this screen and the availability of an alternative, particularly for new users that may find themselves here, we should add a warning to the widgets admin screen that clearly states that changes are published immediately and deep-links to the live preview version. This could also reduce confusion here and elsewhere, as this may be the only place in wp-admin where changes are saved without clicking any sort of publish/submit button.

Attachments (2)

40830.diff (1.2 KB) - added by celloexpressions 7 years ago.
40830.png (50.3 KB) - added by celloexpressions 7 years ago.
With 40830.diff.

Download all attachments as: .zip

Change History (9)

#1 @celloexpressions
7 years ago

  • Component changed from Customize to Widgets

#2 @westonruter
7 years ago

  • Keywords ux-feedback added

A concern with a warning here is that it could contribute to notice fatigue. If a user wants to use the widgets admin screen exclusively, they're not going to want to see this notice persistently forever. Should it be dismissible?

This ticket was mentioned in Slack in #core by westonruter. View the logs.


7 years ago

#4 @ghovens
6 years ago

Hi @celloexpressions,

Thanks for raising this issue. I am doing my first contributing during WordCamp Antwerp, so please forgive me if I am not doing this right.

I think you mention the very root cause of the problem: This is the only place in WP where changes are saved without clicking any button.

In my view a better solution would be to make the experience on the widget screen consistent with general WP behaviour and add a 'save' or 'publish' button instead. What do you think?

Kind regards,

Gijs

This ticket was mentioned in Slack in #design by boemedia. View the logs.


5 years ago

#6 @boemedia
5 years ago

  • Keywords ux-feedback removed
  • Resolution set to maybelater
  • Status changed from new to closed

We discussed this ticket in design triage today. Although we agree that the user flow could be improved, we also think that since it's not broken, it's better to focus on looking forward and design and work on new solutions in a more holistic way. Since this widgets screen is a legacy screen, it won't be a priority for the design team to work on. “Tightening up” is a focus of core design this year, and we’d like to tackle this as a wider part of that effort. I’m going to close this as maybelater.

#7 @desrosj
5 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.