Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#40832 closed defect (bug) (invalid)

Mediaelement fails to load videos when page has 50+ videos

Reported by: urtuk's profile urtuk Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

mediaelement bug and fails to load video when the webpage have 50+ videos in the same page.

Change History (22)

#1 @urtuk
7 years ago

note: it bug with firefox and chrome, but not microsoft edge or internet explorer. all works if the page have only ~20 videos.

#2 @ocean90
7 years ago

  • Keywords reporter-feedback added
  • Summary changed from mediaelement to Mediaelement fails to load videos when page has 50+ videos

Hello @urtuk, welcome to WordPress Trac!

Thanks for your report. Do you have a public test page where we can try to reproduce this issue?

@rafa8626 Are you aware of such an issue?

#3 @urtuk
7 years ago

removed

Last edited 7 years ago by urtuk (previous) (diff)

#4 @rafa8626
7 years ago

@ocean90 No I wasn't aware of that bug. My focus has been to support the upgrade. I'll take a look but just for my knowledge do we need to fix this on the old version?

#5 @urtuk
7 years ago

note: my server use nginx instead of apache. but i don't think there is a relation since it works on other pages (with less videos).

Last edited 7 years ago by urtuk (previous) (diff)

#6 @urtuk
7 years ago

no change after update to new wordpress, i suppose you didn't checked the issue.

Last edited 7 years ago by urtuk (previous) (diff)

#7 @rafa8626
7 years ago

@urtuk Updating to a new WP won't solve your issue. It is still using the same MediaElement package. We are working on upgrading it. As far as testing your websites, I tried them but even the one you said it worked choked. I don't think it was a problem with the plugin, but with the way your infrastructure is serving videos. I'll be happy to look again. And my apologies for not saying anything but as I mentioned I'm working towards updating this plugin. Let me know if you want me to check this again

#8 @urtuk
7 years ago

thanks for your answer. yea i can't figure out this problem, it would be nice if you could check again. link: link removed

and on this page it works for me: link removed

Last edited 7 years ago by urtuk (previous) (diff)

#9 @rafa8626
7 years ago

Ok I'll check this today and I'll use your URLs as a test scenario to test the upgrade as well. I'll let you know my findings. Thanks

#10 @rafa8626
7 years ago

The problem is the URLs. I tried just pasting them in my browser (removed and removed) and they take a lot of time to play. It's not a MEJS issue.

Last edited 7 years ago by rafa8626 (previous) (diff)

#11 @urtuk
7 years ago

it plays instantly, server is in france maybe thats why it's slow to you.
it only bug on the first link i gave you, on other articles it works. maybe it's an issue with nginx but i don't see how.

#12 @urtuk
7 years ago

on page that videos work the duration and image preview of each are displayed, but on page that doesn't (first link) nothing, no metadata.

Last edited 7 years ago by urtuk (previous) (diff)

#13 @rafa8626
7 years ago

I don't know about nginx, since I'm not an expert on system administration. My first advise is: use preload="none", instead of preload="none" when using multiple videos on the same page. Can you try that please?

#14 @rafa8626
7 years ago

I'll take another close it look later with the upgrade to see if I can reproduce that there, but I definitely won't try to use meta as preload, because not all of the videos has that, and IDK how the browsers will deal with that

#15 @urtuk
7 years ago

i did that in the past and it worked yes (changing preload=metadata to none). but then after a wordpress update it worked without it, but it didn't last, i don't know if it came from an other wordpress update or not but it doesn't, and changing preload to none doesn't fix it either. i'm trying again to be sure.

#16 @urtuk
7 years ago

yea you right it works without metadata, its strange because i already tried that weeks ago and it didn't worked. it's annoying to not have duration and preview but it's fine, better that than video not working. i still don't get why it works (with metadata) only on microsoft edge, and no other browser.
thanks i'll consider the problem "fixed". if you think it's browser related and not from the plugin.

#17 @rafa8626
7 years ago

Every browsers deals with that attribute in different ways, and it's not reliable. See https://www.stevesouders.com/blog/2013/04/12/html5-video-preload/, quoting:
The amount of video preloaded varies across the major desktop browsers. Luckily, preload='none' has consistent behavior across all browsers: nothing is buffered. But all other values of PRELOAD vary in how much video data is downloaded. Chrome is aggressive about preloading, going so far as to buffer 25 seconds of video for preload='metadata'. However, it is less aggressive for preload='auto', stopping at 25 seconds while the other desktop browsers download the entire 52 seconds. Firefox 19 and IE 10 are generally less aggressive, buffering zero seconds for three of five preload states. So as you can see, every browser has a different behavior with preload, except with none

#18 @rafa8626
7 years ago

Hope this has been helpful. You can label this as invalid since it is not related to the player itself. Anyway, thanks for reporting this.

#19 @urtuk
7 years ago

  • Resolution set to invalid
  • Status changed from new to closed

#20 @urtuk
7 years ago

yea thanks for your help : )

just one last thing, can you remove the links of my website please?

#21 @rafa8626
7 years ago

Links removed from my comment

#22 @netweb
7 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.