WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#40848 closed defect (bug) (duplicate)

Appending digit(s) to posts, pages and attachment URLs and duplicate content

Reported by: henry.wright Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Canonical Keywords:
Focuses: Cc:

Description

If I visit an attachment page (unattached media for example) and then append some digits to the URL, I see duplicate content.

Steps to reproduce:

  1. Visit an attachment page such as example.com/slug/
  2. Append some random digits to the URL:
  • example.com/slug/5/
  • example.com/slug/16/

You should see the same content on each page.

Change History (6)

#1 @henry.wright
2 years ago

  • Summary changed from Appending digits to unattached media URL and duplicate content to Appending digit(s) to posts, pages and attachment URLs and duplicate content

#2 @henry.wright
2 years ago

I did some more testing and found the problem isn't specific to attachments. You can append digit(s) to posts, pages and attachments and you'll see the same content on every page. Examples:

Unattached attachments (same content on each)

example.com/slug/
example.com/slug/5/
example.com/slug/16/
example.com/slug/544/
example.com/slug/1618/

Posts (same content on each)

example.com/2017/05/15/slug/
example.com/2017/05/15/slug/17/
example.com/2017/05/15/slug/1811/
example.com/2017/05/15/slug/19817/
example.com/2017/05/15/slug/199181/

Pages (same content on each)

example.com/slug/
example.com/slug/2/
example.com/slug/126/
example.com/slug/5144/
example.com/slug/11618/

#3 @SergeyBiryukov
2 years ago

  • Component changed from General to Canonical
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28081.

#4 follow-up: @henry.wright
2 years ago

Hi @SergeyBiryukov this isn't quite the same issue as #28081. That ticket refers to URLs with /page/ in them and this ticket doesn't. I think the issues and solutions might be separate?

#5 in reply to: ↑ 4 @SergeyBiryukov
2 years ago

Replying to henry.wright:

Hi @SergeyBiryukov this isn't quite the same issue as #28081. That ticket refers to URLs with /page/ in them and this ticket doesn't. I think the issues and solutions might be separate?

The current patch on #28081 might only cover one case, but I think the ultimate solution should cover both, since essentially it's the same issue. My comment there refers to non-/page/ URLs to make sure they don't get missed.

If the fix turns out to be separate, we can reopen this ticket, but the same issue has also been reported in #39183 and #39899, so either way it's a duplicate at the moment.

#6 @henry.wright
2 years ago

Thanks for the update Sergey. Glad to see you're already tracking this 👍

Note: See TracTickets for help on using tickets.