WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#40879 closed enhancement (duplicate)

Offer to delete permanently and not only trash, if 'MEDIA_TRASH' constant is set 'true'

Reported by: Presskopp Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Media Keywords:
Focuses: administration Cc:

Description

About trashing media, if we define 'MEDIA_TRASH', true, then why not offer actions to trash OR delete, I ask myself. Right now, you MUST use the trash then.

Attaching a patch to illustrate the idea, it surely would need more work.

Attachments (2)

40879.diff (4.2 KB) - added by Presskopp 3 years ago.
trash.png (21.4 KB) - added by Presskopp 3 years ago.

Download all attachments as: .zip

Change History (3)

@Presskopp
3 years ago

@Presskopp
3 years ago

#1 @dd32
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Adding this would make media act differently from the rest of the Trash functionality in WordPress.

Having Trash enabled specifically forces items to be placed into the trash before they're deleted - That includes Posts, Comments, and when MEDIA_TRASH is enabled, Media too.

I'm marking this as a duplicate of #39613 as it deals with a general "Skip Trash, just delete it" functionality, however #38026 may also be of interest.

Note: See TracTickets for help on using tickets.