WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#41018 closed defect (bug) (invalid)

Post Filter Bug

Reported by: Brandicoot Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Query Keywords:
Focuses: Cc:
PR Number:

Description

Bug: When looking at posts in the WP Admin area, if you apply a filter – eg. June 2017. Nothing will show.

Cause: There is a rogue character ‘s’ at the beginning of the URL query string immediately after the question mark. Remove this letter ‘s’, hit enter and the filter works.

Fix: Find whatever code is introducing this stray character and correct it. Then give the developer responsible a jolly good smack on the bottom.

You’re welcome.

Change History (3)

#1 @dd32
2 years ago

  • Keywords reporter-feedback close added

Hi @Brandicoot and welcome back to Trac,

I can't duplicate what you're seeing, can you perhaps test it without any plugins on a default install?

The URL as provided for me is:

edit.php?s&post_status=all&post_type=post&action=-1&m=201701&cat=0&filter_action=Filter&paged=1&action2=-1

There is indeed a s at the start, but that's completely fine, it expands to s=, ie. a search query with no value, which is expected.
It sounds like you may have a plugin installed which is modifying the query when the s parameter is present, and failing to note that it's empty / not the request it should be modifying.

#2 @Brandicoot
2 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Hi @dd32 . I found the cause of the problem. It's a bug with a plugin called "Search Everything". I've removed it. It was starting to annoy me anyway.

Sincere apologies for wasting your time and thanks for the rapid response. Great support!

Cheers

Chris

#3 @netweb
2 years ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.