WordPress.org

Make WordPress Core

Opened 6 months ago

Last modified 3 months ago

#41026 new defect (bug)

Copy & Paste doesn't copy color styling issue in Wordpress 4.8

Reported by: cliftonc0613 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: major Version: 4.8
Component: Editor Keywords:
Focuses: ui Cc:

Description

Hey guys I have a question about 4.8. So in the last version of 4.7 you could copy colored text and paste it and it stay colored. In 4.8 you cannot do this. Was this a core change or is it an issue. See video
https://www.useloom.com/share/c474162f78764f7d90572a78c5db0b48


Operating System: Macintosh OS X 10.12.5
Screen Resolution: 1920 x 1200
Web Browser: Chrome 58.0.3029.110
Browser Size: 1920 x 1059
IP Address: 71.85.112.91
Color Depth: 24
Javascript: Yes
Flash Version: Not Installed
Cookies: Yes
User Agent:
Mozilla/5.0 (Macintosh; Intel Mac OS X
10_12_5) AppleWebKit/537.36 (KHTML,
like Gecko) Chrome/58.0.3029.110
Safari/537.36

Change History (7)

#1 @jbpaul17
6 months ago

I can confirm that colored text copy/pastes fine in a local install using 4.7.4 but does NOT work in a local install using 4.8.

#2 @jbpaul17
6 months ago

#41027 was marked as a duplicate.

#3 @cliftonc0613
6 months ago

Thanks for the response

#4 @dontwakeme
5 months ago

We are having problems with this bug as well.
Both text color and background color get lost when copying colored text in visial editor.
When you copy and paste colored text in text editor all the spaces between text don't gets displayed - they spaces are still there in the text editor but you actually need to switch to visual editor and add them again before they get displaced in the front end.
Since we work a lot with colored text this increases our workload a lot.
Is this gonna get fixed with WP 4.8.1? Would be really appreciated!

Thanks for your time and help!

#5 @aaronjones0000
4 months ago

Im soooooooooo bummed! you guys didnt get this fixed it appears in 4.8.1! I cut and paste colored text all day, and currently i cant and havent for weeks. please add this bug fix, as soon as you can.

thanks!

#6 @xdizzy12
3 months ago

This also appears to be the case with colored and styled tables. Copy pasting a styled table results in a blank default table. It does copy/paste the data, but all styling will be lost.

#7 @xdizzy12
3 months ago

  • Severity changed from normal to major

For many users a major bug in the WYSIWYG functionality which is now very much broken.

Last edited 3 months ago by xdizzy12 (previous) (diff)
Note: See TracTickets for help on using tickets.