WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 10 months ago

#41033 closed defect (bug) (worksforme)

Cannot Change the Text Color of Links in the WordPress 4.8 Visual Editor

Reported by: jeffr0 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Editor Keywords:
Focuses: Cc:

Description

I'm able to verify the issue reported in the following support thread using Firefox 54 on my Macbook Pro.

https://wordpress.org/support/topic/cant-edit-text-link-color-with-upgrade-to-4-8/

In short, you can not change the color of text in the WordPress 4.8 visual editor if it is turned into a URL first. However, if you change the color of text before it's turned into a link, it remains that color. This seems like a bug.

Change History (3)

This ticket was mentioned in Slack in #forums by zoonini. View the logs.


4 years ago

#2 @GalenGidman
4 years ago

I can confirm this is an issue, not just in Firefox. Seems like (depending on how you select the link) it's just adding a span either around or within the anchor tag and adding the style color attribute to that, instead of adding the style attribute to the link itself. This causes an issue if the link is using the text-decoration CSS property.

#3 @noisysocks
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Looks like this is fixed. If I add a link, select that link, then change the colour using TinyMCE, the link becomes the colour I select. When I view the source I see that a color: rule was added to the <a>.

Note: See TracTickets for help on using tickets.