WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#41040 closed defect (bug) (duplicate)

Menu handling in Customizer, breaks when clicking outside +Add items-button

Reported by: kebbet Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Customize Keywords:
Focuses: javascript Cc:

Description

This might be a bug which pops you out from intended workflow and makes the user confused if a menu exists or not for current theme.

To reproduce.
Enter the customizer.
Click menus
Select your menu you have created on beforehand.
Click + Add Items
Click on the grey area below + Add items.
Tada, you just broke out your intended workflow.

System: Safari 10.1.1 , MacOS 10.12.5

Attachments (1)

customizer-menu-bug.mov (3.8 MB) - added by kebbet 2 years ago.
Video of current behavior.

Change History (4)

@kebbet
2 years ago

Video of current behavior.

#1 @kebbet
2 years ago

  • Summary changed from Menu handling in Customizer, breaks when clicking in outside button to Menu handling in Customizer, breaks when clicking outside +Add items-button

#2 @westonruter
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for reporting this. It's actually a recently discovered issue that is being fixed in #40981.

#3 @westonruter
2 years ago

@kebbet The fix has now landed in trunk via [41020].

Note: See TracTickets for help on using tickets.