WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 5 months ago

#41084 closed defect (bug) (invalid)

Multiple WYSIWYG editors ( wp_editor function) not working in widgets due to tinymce.js error

Reported by: Blackbam Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Editor Keywords: reporter-feedback
Focuses: administration Cc:
PR Number:

Description

The wp_editor()-output is not working within widgets if it appears more than once.

Have a look at the following discussion on stackexchange.wordpress.com where the bug is described in detail. The community has not found a fix yet:

https://wordpress.stackexchange.com/questions/269853/wordpress-4-8-using-multiple-wysiwyg-editors-with-media-inside-of-widgets-how-t

With more and more Plugins (e.g. page builders) using widgets this is a serious limitation a fix is desired.

Change History (2)

#1 @ocean90
2 years ago

  • Keywords reporter-feedback added
  • Version changed from 4.9 to 4.8

Hello @Blackbam, welcome to WordPress Trac!

Thanks for your report. Can you provide an easy test case in form of a plugin so we can try to replicate the issue?

#2 @pento
5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket, as we're unable to reproduce this issue without more information.

Note: See TracTickets for help on using tickets.