WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#41103 closed enhancement (invalid)

Widgets on customize.php page should refresh after data was sent

Reported by: alexvorn2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Widgets Keywords:
Focuses: Cc:

Description

On widgets.php page, widgets are refreshed after you press Save button, but in customize.php page widgets - do not refresh.

Is this by design ?, because I think widgets should work the same way the do on widgets.php page.

Change History (3)

#1 @alexvorn2
4 years ago

I noticed that widgets DO refresh but not every time, only when the number of inputs are greater then the original state, so it does not work It should be.

#2 @alexvorn2
4 years ago

So my ticked is to make widgets refresh every time on customize.php page like they do on widgets.php page.

Last edited 4 years ago by alexvorn2 (previous) (diff)

#3 @westonruter
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

@alexvorn2 do you mean whether or not there is an "Apply" button? This is indeed by design that the widgets in the customizer not get fully refreshed. The presence of the Apply button indicates that the the JS logic wasn't able to sync the values from the server update to the form in the UI. For more info on this, see § No more Update button (usually) at https://make.wordpress.org/core/2014/04/17/live-widget-previews-widget-management-in-the-customizer-in-wordpress-3-9/

Note: See TracTickets for help on using tickets.