Make WordPress Core

Opened 7 years ago

Closed 3 months ago

Last modified 3 months ago

#41104 closed enhancement (fixed)

Add "Site" to the "New" admin-bar dropdown

Reported by: johnjamesjacoby's profile johnjamesjacoby Owned by: joedolson's profile joedolson
Milestone: 6.5 Priority: normal
Severity: normal Version: 3.0
Component: Toolbar Keywords: has-patch has-testing-info commit
Focuses: multisite Cc:

Description

For multisite installations, it would be nice to have a shortcut to create a new site under the "New" admin-bar menu.

  • Every other single-site object is already listed (posts, pages, etc...)
  • "User" is listed, and you can add a new User to a site or install, but from the site dashboard
  • Visually, it should be a separate, secondary menu group (probably at the top?)
  • That secondary group could be used for any "network/global" Add shortcut

Attachments (6)

Screen Shot 2017-06-20 at 1.06.44 PM.png (220.4 KB) - added by johnjamesjacoby 7 years ago.
This is the dropdown I'm talking about (hard to describe using words)
41104.diff (733 bytes) - added by sabernhardt 3 years ago.
single link option based on 49040.diff
41104.2.diff (788 bytes) - added by joedolson 4 months ago.
Refreshed patch
41104.png (14.7 KB) - added by joedolson 4 months ago.
Screenshot with patch
41104-alt.png (14.6 KB) - added by joedolson 4 months ago.
Alternate look with separator
41104.alt.diff (2.4 KB) - added by joedolson 4 months ago.
Alternate patch with CSS changes

Download all attachments as: .zip

Change History (24)

@johnjamesjacoby
7 years ago

This is the dropdown I'm talking about (hard to describe using words)

#1 @sabernhardt
4 years ago

  • Keywords close added

Related/duplicate: #49040

(I recommend closing this ticket because the other has a patch)

#2 @SergeyBiryukov
4 years ago

  • Component changed from Administration to Toolbar
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #49040.

#3 @johnjamesjacoby
4 years ago

That issue is the duplicate of this one, so this ticket being closed goes against convention.

The chronology is important, because it keeps code changes closely coupled to the initial discovery and discussion.

Unless protocol has changed somewhere I haven’t seen, the patch on that issue should have been brought over here instead.

@sabernhardt
3 years ago

single link option based on 49040.diff

#4 @sabernhardt
3 years ago

  • Keywords has-patch needs-testing added; 2nd-opinion close removed
  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened

OK, it would have been better to close the other ticket as duplicate.

I don't know what else would go into a secondary menu group, so I simply iterated on @henry.wright's patch 49040.diff:

  • Changing the link reference to network_admin_url( 'site-new.php' ), as it is in the dashboard widget
  • Moving this additional link outside the foreach loop
  • Moving is_multisite() before the capabilities check, to follow the 'Edit Site' link example
  • Editing the ID to 'add-new-site' to avoid confusion with Jetpack's 'new-site' link
  • Adding to the DocBlock

#5 @sabernhardt
3 years ago

#49040 was marked as a duplicate.

#6 @joedolson
7 months ago

  • Milestone changed from Awaiting Review to 6.5
  • Owner set to joedolson
  • Status changed from reopened to accepted

This seems like a totally reasonable addition; seems like it should just be done. Slating for 6.5, because I think it should be done.

#7 @rajinsharwar
6 months ago

  • Keywords 2nd-opinion added

I am not sure if this will be really necessary, but my opinion will be to Add a "Add New" option on the Network Admin dashboard, and show there, the options of adding a new "User", and a new "Site". Because, generally in a subsite's dashboard, network admins don't generally create sites. They work to administer settings related to that specific subsite. I am not really sure if adding a "Site" option would be helpful for the users.

Even if we consider adding the "Site" for the Add New option for the subsites dashboard, I believe we should add an "Add new" option in the admin toolbar for the Network admin dash. (This will be a part of another ticket though, just proposing and asking for feedback.)

#8 @joedolson
4 months ago

  • Keywords 2nd-opinion removed

Hi, @rajinsharwar!

There is already an option to add a new site or a new user on the network admin dashboard; the text is "Create a New Site" and "Create a New User", so I'm not sure that what you're proposing would be anything new.

Adding this to the admin bar is intended to give the super admin role a shortcut without needing to first navigate back to the network admin. It just shortens that navigation path when administering a subsite. This can be a frequent action for large networks, so it would be convenient.

Otherwise, if you have an additional proposal, I think that would be best done in a separate ticket, to avoid confusing issues here.

@joedolson
4 months ago

Refreshed patch

@joedolson
4 months ago

Screenshot with patch

@joedolson
4 months ago

Alternate look with separator

@joedolson
4 months ago

Alternate patch with CSS changes

#9 @joedolson
4 months ago

  • Keywords has-testing-info 2nd-opinion added

Two possible patches, depending on whether we feel the visual separator is necessary. It may be somewhat helpful to differentiate "on this site" and "outside of this site", but I wouldn't consider it crucial.

Opinions appreciated.

Testing instructions:

  • On a multisite network, verify that 'Site' is present in the "New" submenu when on either the network admin or a subsite admin.
  • Verify that 'Site' is not present if active as a user without permissions to create new sites.

#10 @sabernhardt
4 months ago

The link text could include "network" (such as "Network site" or "Site in network") to help clarify that the link does not relate to the current site.

The proposed top border achieves the visual separation for a secondary item, though I am not fond of how that looks. It could be better with a margin-top of 4 pixels instead of padding.

For another possibility, the link to add a new site could have an icon such as multisite's three houses.

#11 @joedolson
4 months ago

I think that the extra text is not really necessary. While the word 'Site' doesn't explicitly state that it's outside the current site, I think there are two factors that help with that:

1) Anybody with access to this is a network super admin, and should be assumed to understand that
2) adding a new 'site' has no meaningful context on a subsite.

It could run into problems if anybody added a custom post type with the name 'Site', but that seems unlikely.

Adding an icon could give us what we need, though.

#12 @huzaifaalmesbah
3 months ago

I totally agree with you @joedolson. I also believe that additional text is not necessary.

#13 @audrasjb
3 months ago

  • Keywords needs-testing removed

I tested both patch and they work fine.

I prefer the approach in 41104.2.diff. Adding a separator is not mandatory since multisite owners probably know what a new Site is in their context. Plus, it only shows for users who are able to create new sites (admin/super admins).

Also, the separator in the alternate patch looks a bit weird (I think the bottom padding of the "User" item is too small).

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


3 months ago

#15 @joedolson
3 months ago

  • Keywords commit added; 2nd-opinion removed

#17 @joedolson
3 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 57600:

Toolbar: Add adminbar link for new sites in network installs.

Add a link that allows network administrators to go to the new site page from the "New" menu in the adminbar.

Props johnjamesjacoby, sabernhardt, joedolson, rajinsharwar, huzaifaalmesbah.
Fixes #41104.

Note: See TracTickets for help on using tickets.