Make WordPress Core

Opened 7 years ago

Closed 2 years ago

Last modified 2 years ago

#41119 closed defect (bug) (invalid)

Plugins failing trying to use wp_generate_password() function

Reported by: jamiefryatt's profile jamiefryatt Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Plugins Keywords: reporter-feedback
Focuses: Cc:

Description

I've been using a plugin called Woozone, and found a problem when i moved my site to AWS Lighttail, i don't know if this is the same elsewhere. I didn't have this problem with the same setup using AWS EC2, so there might be something in that or how the errors are handled.

Basically i found that the plugin wanted to use wp_generate_password, but couldn't and was throwing a 500 fatal error... I did some debugging and found that in the wp-settings.php file, the pluggable.php and its depreciated version were loading after the plugins. To fix my error i just moved that to load before the plugins and everything worked again.

Not sure if this is a bug, or worth reporting, but it was causing me issues so i thought i'd let you know.

Change History (2)

#1 @azouamauriac
2 years ago

  • Keywords reporter-feedback added
  • Resolution set to invalid
  • Status changed from new to closed

hello @jamiefryatt, welcome to WordPress Trac! Thanks for the ticket.

I'm unable to reproduce your bug; as this bug needs a third party plugin, I suggest you to report it on this plugin support page first.

But feel free to get back if you think this bug is related wordpress core.

best regards.

Last edited 2 years ago by azouamauriac (previous) (diff)

#2 in reply to: ↑ description @SergeyBiryukov
2 years ago

  • Milestone Awaiting Review deleted

Replying to jamiefryatt:

Basically i found that the plugin wanted to use wp_generate_password, but couldn't and was throwing a 500 fatal error... I did some debugging and found that in the wp-settings.php file, the pluggable.php and its depreciated version were loading after the plugins.

Just wanted to note that this is intentional, to let any plugin override any of the functions in pluggable.php.

This seems quite similar to #21612. The plugin in question most likely tried to use the function before WordPress was fully initialized. It should use an appropriate hook instead, see comment:2:ticket:21612 for more details.

Last edited 2 years ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.