WordPress.org

Make WordPress Core

Opened 15 years ago

Closed 12 years ago

#4113 closed defect (bug) (wontfix)

Trigger database update error string from XMLRPC/APP

Reported by: redsweater Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2
Component: XML-RPC Keywords: needs-patch
Focuses: Cc:

Description

When a user updates to a version of WordPress requiring a database update, any attempt to edit the blog through the wp-admin interface triggers a notice that the user needs to update the database.

It would be nice if the same type of error could be detected and conveyed to clients of the XMLRPC and APP interfaces.

I just tested against an updated 2.2 installation, where my attempts to post through the XMLRPC interface failed with a cryptic database error string (it turns out the wp_categories table needed the recently added "type" column).

Going to the admin interface quickly revealed the cause. But it would be nice if the RPC error was, instead of a database access exception, something along the lines of:

"Your WordPress database is out-of-date, and must be upgraded before you can continue. Please visit the administrator's interface of your WordPress installation to perform the upgrade."

Daniel

Change History (5)

#1 @rob1n
15 years ago

  • Milestone changed from 2.2 to 2.3

#2 @josephscott
14 years ago

  • Cc josephscott added

Having a more meaningful error would be good.

#3 @DD32
13 years ago

  • Keywords needs-patch added

Something along the lines of "[XML|ATOM] API is currently disabled until an administrator accesses the administration panel to update the database" in the same spot as the "Sorry, XML API is not enabled" error would be good..

#4 @hakre
12 years ago

Close in the lack of interest?

#5 @ryan
12 years ago

  • Milestone 2.9 deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.