WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#41133 closed defect (bug) (worksforme)

WP 4.8 on IIS unable to upload media

Reported by: mikeolee Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Media Keywords:
Focuses: administration, multisite Cc:

Description

We are having this problem on instances running WP on IIS 8. When we updated to 4.8 the Media area and media uploads are not working correctly. Trying to add media from within the WYSIWYG editor for all content types does not work. We are getting and error that consists of the name of the file "my-file.png" and the error "An error occurred in the upload. Please try again later."

We get this error in the Media library as well when trying to upload an image, BUT only in the "grid" mode and the file seems to actually load as we see it when in "list" mode. When in the "list" mode it seems to work, but the blue task bar seems to get stalled on "Crunching..." but the file, again, is actually uploaded.

Attachments (2)

wp-4-8-insert-media-error.png (2.9 KB) - added by mikeolee 4 years ago.
Error as seen on Insert Media
wp-4-8-media-grid-mode-wheel-spins.png (6.5 KB) - added by mikeolee 4 years ago.
Shows Grid view with wheel that just spins

Download all attachments as: .zip

Change History (7)

@mikeolee
4 years ago

Error as seen on Insert Media

@mikeolee
4 years ago

Shows Grid view with wheel that just spins

#1 follow-up: @joemcgill
4 years ago

Hi @mikeolee,

Thanks for the report. Can you give us any additional information about this error?

  • Are you seeing any additional errors in your browser's javascript console?
  • What browser are you using, and can you reproduce it on multiple browsers?
  • Do you have any plugins installed or theme functionality that would affect image uploads?

Thanks.
Joe

#2 in reply to: ↑ 1 @mikeolee
4 years ago

The Console gives 'XHR finished loading: POST "https://ourURL/wp-admin/admin-ajax.php".' about every 10-30 seconds, but nothing else.

We are getting the same issue in Chrome, FireFox and Edge (all latest stable versions).

Regarding Plugins: We have disabled all plugins in two of our installations, and the issue persists.

Regarding Themes: I did not try this earlier, but when trying to add a theme to switch to, we received the following error:

"An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums."

Replying to joemcgill:

Hi @mikeolee,

Thanks for the report. Can you give us any additional information about this error?

  • Are you seeing any additional errors in your browser's javascript console?
  • What browser are you using, and can you reproduce it on multiple browsers?
  • Do you have any plugins installed or theme functionality that would affect image uploads?

Thanks.
Joe

#3 @mikeolee
4 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

This was an issue with the Theme we were using. This caused several issues relating to the media area with did not allow for several items in WP 4.8 to work.

#4 @laptopleon
4 years ago

  • Focuses multisite added

I'd like to add that we had identical symptoms, (error text at uploading, spinning wheel, images still uploaded despite error text, yet not being able to use them in the editor, etc – on Mac OS 10.11 Safari, Firefox and Opera, and Windows browser by our client) though on a Linux webserver. Despite errors and refusing screens, images were added to the Media Library, but couldn't be used in the editor.

We're also using a multisite, with a custom theme.

For now, we rolled back to 4.7.3 until there is a fix. (We suspect the bug is in since 4.7.4 or 4.7.5)

Should we open a separate ticket for it?

#5 @netweb
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.