WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#4117 closed defect (bug) (fixed)

Non-published, multi-page post page links don't work when permalinks enabled

Reported by: Viper007Bond Owned by: rob1n
Milestone: 2.2 Priority: normal
Severity: normal Version: 2.2
Component: Administration Keywords: has-patch commit
Focuses: Cc:

Description

To replicate:

  1. Write a post. Make it paged by putting <!--nextpage--> somewhere in the post.
  2. Click the "Save and continue editing" button.
  3. Click the "Preview" link.
  4. Click the "2" link which should take you to the second page.

The URL in the address bar will be something like this:

http://site.com/?p=8/2/

It should be this since the post doesn't have a permalink yet:

http://site.com/?p=8&page=2

Attachments (1)

post-templates.patch (1.8 KB) - added by Viper007Bond 8 years ago.
I think this'll do the trick

Download all attachments as: .zip

Change History (6)

@Viper007Bond8 years ago

I think this'll do the trick

comment:1 @Viper007Bond8 years ago

Originally reported by drz: #4106

comment:2 @Viper007Bond8 years ago

Also probably applies to the 2.0.x line if we want to fix it there.

comment:3 @rob1n8 years ago

  • Owner changed from anonymous to rob1n

comment:4 @rob1n8 years ago

  • Keywords commit added

Yep. Reproduced, and the patch fixes it.

comment:5 @rob1n8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5242]) Don't use fancy permalinks on draft previews. Props Viper007Bond. fixes #4117

Note: See TracTickets for help on using tickets.