WordPress.org

Make WordPress Core

Opened 5 months ago

Last modified 4 months ago

#41186 new defect (bug)

4.8 Video Widget Not Working for External YouTube URL

Reported by: foreverlearning Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.8
Component: Media Keywords: close reporter-feedback
Focuses: Cc:

Description

The problem occurs when trying to use the new 4.8 video widget when selecting external URL and using a YouTube URL - an error is returned stating that it's an incorrect file type. I"ve tried this on two different domains and have gone through the process of disabling/deleting all plug ins, switching to default themes etc. and the issue still occurs. I will attempt to attach a screenshot of the error
Thank you.

DAn

PS: Be kind this it the first time I've reported a bug.

Attachments (1)

video-widget-error.png (13.5 KB) - added by foreverlearning 5 months ago.
Screenshot of the Error

Download all attachments as: .zip

Change History (10)

@foreverlearning
5 months ago

Screenshot of the Error

#1 @swissspidy
5 months ago

#41201 was marked as a duplicate.

#2 @SergeyBiryukov
5 months ago

  • Component changed from General to Media

#3 @DrewAPicture
5 months ago

  • Keywords close added

@foreverlearning Welcome to Core Trac!

I tried a variety of YouTube URLs, both the shortened and full verions, and wasn't able to reproduce the bug you described. I also tried it both in the Widgets screen an in the Widgets panel in the Customizer.

https://cl.ly/2d0t141T363X/download/Screen%20Shot%202017-06-29%20at%2011.57.41%20AM.png

Separately, I also tested the issue specifically with YouTube embed URLs described in #41201 and confirmed that issue.

#4 follow-up: @foreverlearning
5 months ago

I agree that it does work and I've gotten it to work on some of my sites. But some do have issues. Not sure what to say. Something isn't right, just don't know what it might be.
Made a 2 minute YouTube video. https://youtu.be/UeN2kYd5FSs

#5 in reply to: ↑ 4 @SergeyBiryukov
5 months ago

  • Keywords reporter-feedback added

Replying to foreverlearning:

I agree that it does work and I've gotten it to work on some of my sites. But some do have issues.

Could you check if REST API is enabled on those sites? I've seen some similar reports that were caused by disabling it.

#6 @foreverlearning
5 months ago

Hi Sergey thanks for the suggestion. A bit above my pay grade. I called Host Gator and asked them to get back to me. If you can provide any guidance about rest api that would be great and I'll be sure to check your suggestion.

#7 @foreverlearning
5 months ago

To elaborate more I'm assuming that rest api is on the server side since in m demo video I'm using the 2017 theme and getting the error. True?

#8 @afercia
4 months ago

For reference: I've tested with the same URL used in @foreverlearning test video posted above: https://youtu.be/FclScfPoKes and it's working for me.

#9 @foreverlearning
4 months ago

@afercia I have actually posted the same video on some sites and it works. There is an issue the question is what is the issue dependencies? Hopefully it will get fixed at some point. As mentioned I've been down the usual rabbit holes of deactivating and actually deleting all plug ins and have still had the issue. I wish I was more technically experienced and knowledgeable and could provide more information. I just know that it doesn't always work and it seems to be site dependent.

Note: See TracTickets for help on using tickets.