WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 3 months ago

#41187 closed defect (bug) (fixed)

Deprecated Functions warning on import screen in the WordPress 4.8 Version

Reported by: kamalahmed Owned by:
Milestone: WordPress.org Priority: normal
Severity: normal Version:
Component: Import Keywords: has-screenshots
Focuses: Cc:

Description

Hello, When importing WordPress Data using WordPress import feature, I found the following errors. Notice: wp_get_http is <strong>deprecated</strong> since version 4.4.0! Use WP_Http instead. in /Applications/MAMP/htdocs/themedev/wp-includes/functions.php on line 3831

You can reproduce the error by importing WordPress site data from a live site with images and other content to the site and enabling Debug mode to TRUE.

I have also added the screenshot.

https://www.kamaldeveloper.com/wp-content/uploads/2017/06/Screen-Shot-2017-06-27-at-11.00.19-PM.png Thank you very much.

Attachments (1)

Screen Shot 2017-06-27 at 11.00.19 PM.png (294.2 KB) - added by kamalahmed 11 months ago.
screenshots of the error

Download all attachments as: .zip

Change History (4)

@kamalahmed
11 months ago

screenshots of the error

#1 @DrewAPicture
11 months ago

  • Component changed from General to Import
  • Keywords has-screenshots added

#2 @norbou
3 months ago

I can confirm as well on PHP 7.0.2 on WP 4.9.4: [08-Feb-2018 08:41:56 UTC] PHP Notice: The function Screen_icon <strong> is not supported by </strong> since version 3.8.0 and no workarounds are available on the current version of WordPress. in /wp-includes/functions.php on line 3842 [08-Feb-2018 08:41:56 UTC] PHP Notice: Funkce get_screen_icon <strong> is not supported by </strong> since version 3.8.0 and no workarounds are available on the current version of WordPress. in /wp-includes/functions.php on line 3842 [08-Feb-2018 08:43:17 UTC] PHP Notice: Funkce wp_get_http <strong> is not supported by </strong> since the version of 4.4.0! Please use the WP_Http function instead. in /wp-includes/functions.php on line 3839

#3 @ocean90
3 months ago

  • Milestone changed from Awaiting Review to WordPress.org
  • Resolution set to fixed
  • Status changed from new to closed
  • Version 4.8 deleted

Version 0.6.4 includes the fix for this and is now available: https://wordpress.org/plugins/wordpress-importer/

Note: See TracTickets for help on using tickets.