WordPress.org

Make WordPress Core

Opened 2 years ago

Last modified 2 years ago

#41199 reopened enhancement

Allow the optional editing of an author slug

Reported by: dartiss Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Users Keywords:
Focuses: administration Cc:
PR Number:

Description

At the moment an author slug cannot be changed, although plugins are available to allow this. I believe that WordPress should be able to do this, "out of the box".

Changes to names, whether through marriage, change of sexual orientation or many other reasons, are important to the individuals that go through it. The original slug, by remaining unchanged, is still the link to an authors page on WordPress and may be the last thing an author, post name change, wants to see.

I think, as a very basic change, there should be the option to change this slug, if required (but not a requirement because of how it will affect existing author links). To take this a stage further, if possible, we should also add the option to allow the original slug to also work too.

Change History (5)

#1 @SergeyBiryukov
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #39123.

#2 @dartiss
2 years ago

Thanks @SergeyBiryukov - hadn't seen that ticket (I did search beforehand, honest!). I'll update it with some extra keywords to avoid any future confusion.

#3 @dartiss
2 years ago

Okay, it looks like I can't edit the keywords. @SergeyBiryukov - could you add 'slug' and 'author' as keywords to that original post to make it easier to find? Thanks.

#4 @johnbillion
2 years ago

  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version trunk deleted

This isn't exactly a duplicate of #39123. The user_login and user_nicename fields are often the same, but not always. It should be possible to modify them independently.

#5 @Compute
2 years ago

Something that is possible with the plugin https://da.wordpress.org/plugins/edit-author-slug/ - could be used as inspiration.

Note: See TracTickets for help on using tickets.