WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#41202 closed enhancement (duplicate)

Open link of plugin author in new tab

Reported by: rinkuyadav999 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Plugins Keywords: has-patch dev-feedback target-blank
Focuses: ui, accessibility Cc:

Description

/wp-admin/plugins.php

There is name of plugin author and link if added by plugin author Like Version 1.0.1 | By plugin author ......

This link is external link in all case. This link is not part of current WordPress website so it should open in new tab instead in same tab.

Right now when a WordPress user click on this link, he leave his website and redirect on provided external link. Expected: Open this external link in new tab because it is not part of Dashboard.

Attachments (2)

open-website-of-plugin-author-in-new-tab.png (21.2 KB) - added by rinkuyadav999 3 years ago.
Open website of plugin author in new tab
41202#1.patch (726 bytes) - added by rinkuyadav999 3 years ago.
Patch

Download all attachments as: .zip

Change History (7)

@rinkuyadav999
3 years ago

Open website of plugin author in new tab

@rinkuyadav999
3 years ago

Patch

#1 @rinkuyadav999
3 years ago

  • Keywords has-patch dev-feedback added

#2 @kakshak
3 years ago

Hello @rinkuyadav999
WordPress will not open the link in a new tab because of consistently throughout in the admin-area.
I think Open the links in a new tab is not a good idea for user experience. If a user wants to open links in the new tab then they have the option to use Ctrl+click from the keyboard.
If you give target="_blank" that means you are forcing the user to open the link in a new tab even if he doesn't want.
You can check that "Visit plugin site" link is also not opening in new tab.

#3 @rinkuyadav999
3 years ago

Hi @kakshak

Thanks for your feedback. Let wait for more feedback.

#4 @afercia
3 years ago

  • Focuses accessibility added
  • Keywords target-blank added

There is an ongoing discussion about links with target _blank, see https://core.trac.wordpress.org/query?keywords=~target-blank.
Ideally, users should have the choice to open a link. Browsers have tabbed navigation since years and years. In very, limited, specific cases, for example to avoid data loss, it might make sense to use target _blank. In this case, users should be informed the link is going to open in a new tab (or window, depending on browser settings).

Last edited 3 years ago by afercia (previous) (diff)

#5 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20839.

Note: See TracTickets for help on using tickets.