WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#41212 closed defect (bug) (duplicate)

Not escaping all special characters in RSS feed

Reported by: marco.marsala Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Feeds Keywords:
Focuses: Cc:

Description

Some special characters in post content, like SOH, leads to invalid RSS feed.

These characters may come in if the content is pasted from Word or PDF. I believe the text and visual editors should strip these characters too.

Change History (3)

#1 @mdgl
2 years ago

Likely duplicate of #19998, #28506. See also #25872.

#2 @marco.marsala
2 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19998.

#3 @netweb
2 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.