WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 2 weeks ago

#41232 closed enhancement (duplicate)

Cache translations and nav menus

Reported by: szepe.viktor Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: General Keywords: close
Focuses: performance Cc:

Description

I've noticed caching translations and navigation menus HTML output makes WordPress load much faster. (Using persistent object cache)

I am experimenting with these two (an the_content() caching) in this repo
https://github.com/szepeviktor/tiny-cache

Please consider caching these two in the core.
Thanks.

Change History (4)

#1 @swissspidy
4 years ago

For caching menus there's already #36225.

#2 @SergeyBiryukov
4 years ago

And for translations there's #17268 :)

Version 0, edited 4 years ago by SergeyBiryukov (next)

#3 @SergeyBiryukov
4 years ago

  • Keywords close added

#4 @hellofromTonya
2 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hello @szepeviktor,

Welcome to WordPress Trac! Thank you for this suggestions.

Both the menu and translation caching are tracked in separate tickets, as noted previously.

I'm closing this ticket. I invite you to contribute to the other tickets to help them move forward.

For triage contributors:
This ticket is a duplicate of multiple tickets. For closing purposes, I've marked it as a duplicate of the menu caching ticket #36225 which seems most closely related.

Note: See TracTickets for help on using tickets.