WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 months ago

Last modified 5 weeks ago

#41233 closed enhancement (duplicate)

Plugin activation / deactivation is a pain for network.

Reported by: MaximeCulea Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Networks and Sites Keywords:
Focuses: multisite Cc:
PR Number:

Description

I think plugin activation / deactivation is a pain for network, as hooks are not correctly launched.

Even if the $network_wide parameter passed to the activation/deactivation hook determines whatever to do, there are still cases when it's not working.

We also have to think about one though, which is when creating a new site. It's indeed tricky.

I am using this plugin to manage this, and some times I am doing it programmatically, which is the next way :

I do it by using REST API and/or cron, to iterate each sites of the network for wanted plugin activation / deactivation.

Change History (4)

#1 @flixos90
3 years ago

Related: #37656

#2 @MaximeCulea
2 years ago

Hi,
Ok then @flixos90, do we need to close this ticket ?
Thx

#3 @MaximeCulea
3 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #37656.

#4 @desrosj
5 weeks ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.