WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#41276 closed feature request (duplicate)

Scroll option for My Sites list for many sites.

Reported by: iamabdurrehman Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: General Keywords:
Focuses: accessibility, administration, multisite Cc:

Description

Hi there!

I was wondering if you consider making a scrolling option for the list of sites in the network. When there are too many sites in the network from the top list of the network only sites visible in the screen area shows up and the rest of sites don't. Please have a look at the GIF attached.

http://j.mp/2u6wccL

Thanks in advance for your consideration.

With kind regards,

Abd Ur Rehman
Elegant Themes Tech Support Team

Change History (6)

#1 follow-up: @johnjamesjacoby
3 years ago

Hello @iamabdurrehman, congratulations on your second ticket here. This is a problem we’ve discussed at length several times, but have yet to take any action on. Here’s my brain-dump on the subject:

  • The number of users who actually run into this problem is very very small, but for those users it’s extremely problematic
  • Creating that menu is still costly, requiring a blog-switch to each site to get the site name for the menu label
  • The Flow Team (specifically @ryan) has researched this deeply for WordPress.com (and Jetpack) so we have that to lean on
  • To address this, we should not try to improve the existing implementation, but rather design a new feature to help with the act of large-network navigation
  • At one point, @azaozz did design a scrollable menu, and even one with a search bar, but these were all scrapped due to browser render issues, mobile issues, and a lack of a proper multi-blog search functionality in core
  • No plugins currently adequately address this that I am aware of, though some kind of mega-menu that uses site icons might be neat if site icons were more popularly used

Because this is a menu, it’s something we can work on privately in a plugin if we’d like to, and then merge into core if it’s deemed worthy, good & popular enough.

Last edited 3 years ago by johnjamesjacoby (previous) (diff)

#2 in reply to: ↑ 1 @iamabdurrehman
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for taking look at my request.

Yeah! I can imagine that and you're right. There aren't so many users having this issue but It's really quite time-consuming switching into sites when have to replicate any issue with other themes in the network because of no scroll menu.

Well, I hope 💯 % there will be something better coming up even users are small.

Thanks!

Kind Regards,

Abd Ur Rehman

Replying to johnjamesjacoby:

Hello @iamabdurrehman, congratulations on your second ticket here. This is a problem we’ve discussed at length several times, but have yet to take any action on. Here’s my brain-dump on the subject:

  • The number of users who actually run into this problem is very very small, but for those users it’s extremely problematic
  • Creating that menu is still costly, requiring a blog-switch to each site to get the site name for the menu label
  • The Flow Team (specifically @ryan) has researched this deeply for WordPress.com (and Jetpack) so we have that to lean on
  • To address this, we should not try to improve the existing implementation, but rather design a new feature to help with the act of large-network navigation
  • At one point, @azaozz did design a scrollable menu, and even one with a search bar, but these were all scrapped due to browser render issues, mobile issues, and a lack of a proper multi-blog search functionality in core
  • No plugins currently adequately address this that I am aware of, though some kind of mega-menu that uses site icons might be neat if site icons were more popularly used

Because this is a menu, it’s something we can work on privately in a plugin if we’d like to, and then merge into core if it’s deemed worthy, good & popular enough.

#3 @SergeyBiryukov
3 years ago

  • Component changed from General to Toolbar
  • Focuses accessibility removed
  • Resolution changed from invalid to duplicate
  • Type changed from feature request to enhancement

Duplicate of #15317.

#4 follow-up: @MaximeCulea
3 years ago

  • Component changed from Toolbar to General
  • Focuses accessibility added
  • Type changed from enhancement to feature request

@iamabdurrehman I did encounter the same issue on a very large network, even multi network. After a lot of testing, I finally chose to do the next thing.
As an admin don't play enought with the site listing and they are not all listed there, I just hided the drop down. Instead, I displayed a link to a custom admin page which was similar to the sites one, but with more information.
The advantage is that it worth it for speeding up the back-office. I was able to display information, and more, as I wanted.

#5 in reply to: ↑ 4 @iamabdurrehman
3 years ago

Hey there!

Thanks for the suggestion. Yeah! but I'm just switching by changing the URLs rather than going to the listing.

Replying to MaximeCulea:

@iamabdurrehman I did encounter the same issue on a very large network, even multi network. After a lot of testing, I finally chose to do the next thing.
As an admin don't play enought with the site listing and they are not all listed there, I just hided the drop down. Instead, I displayed a link to a custom admin page which was similar to the sites one, but with more information.
The advantage is that it worth it for speeding up the back-office. I was able to display information, and more, as I wanted.

#6 @netweb
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.