WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#41289 closed defect (bug) (worksforme)

Admin menu column flicking up and down when media picker shown

Reported by: GrahamArmfield Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Media Keywords: reporter-feedback
Focuses: ui, accessibility Cc:
PR Number:

Description

When I'm editing a post and activate the 'Add Media' button, the media dialogue panel appears. Whilst the panel is open, it's possible to see that the main admin menu column is flicking up and down.

The same happens when I try to edit an image in the post.

Whilst being mildly annoying for most people, it could be severely annoying for those with autism, ADHD, dyslexia etc.

I've created a video to illustrate the issue: See: https://youtu.be/frM6ZNm6gCw

I'm using Chrome 59 on Windows 10. The site is running WP 4.8 on PHP7.

Change History (8)

#1 follow-up: @swissspidy
2 years ago

Related / Possible duplicate: #39859.

#2 in reply to: ↑ 1 @GrahamArmfield
2 years ago

Replying to swissspidy:

Related / Possible duplicate: #39859.

I couldn't comment on that, but the effect in #39859 seems to just happen once. In this instance, the flicking continues for as long as the media modal is open.

But forgive me if I'm misunderstood what's going on in #39859.

#3 @xkon
2 years ago

This bumping effect isn't happening on any of my machines ( Using latest Chrome / Firefox / Opera / Edge ). I can understand the problem at hand but I'm trying to reproduce it for quite a while now even with installing / uninstalling extra plugins to see if they change anything on the Admin Bar by adding their custom menus etc but without success.

Might there be a plugin on your side that causes this with a broken menu setup? I've seen a lot of plugin developers trying to bypass the reasoning behind the WordPress admin menu adding custom jquery events etc to be able to have a 'perfect' menu. I'm not against that but it usually causes trouble.

Just a thought that occurred to me as there was no way for me to make the bar behave as in your video.

Best regards,
Konstantinos

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


2 years ago

#5 @joedolson
2 years ago

  • Keywords reporter-feedback added

#6 follow-up: @afercia
2 years ago

I couldn't reproduce it too. @GrahamArmfield probably one of your plugins?

#7 in reply to: ↑ 6 @GrahamArmfield
2 years ago

Replying to afercia:

I couldn't reproduce it too. @GrahamArmfield probably one of your plugins?

Hi Andrea, have had a chance to test this again today by disabling plugins etc, and it's no longer happening... One of life's unexplained mysteries I guess.

Happy for this to be closed.

#8 @swissspidy
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.